cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prashant Kumar Mishra <prashantkumar.mis...@citrix.com>
Subject KVM Migration problem
Date Thu, 04 Oct 2012 04:29:30 GMT
Sorry by mistake I putted wrong subject , it should be” KVM Migration problem”
From: Prashant Kumar Mishra
Sent: Wednesday, October 03, 2012 11:57 PM
To: Edison Su; 'cloudstack-dev@incubator.apache.org'
Cc: Chandan Purushothama; Sudha Ponnaganti; Rohit Yadav; Suresh Sadhu; Shweta Agarwal; Sowmya
Krishnan; Sailaja Mada; Abhinav Roy; Srinivas Vejalla; Alex Huang
Subject: RE: System VMs are not coming up (CS-XS6.0.2)

Hi Everyone,
I am having two  KVM(Rhl6.3) host in a cluster ,I was trying to put one of the host in maintenance
mode but got some error messages in log and host went in “ErrorInMaintenance”state .I
am using CS(Rhl6.3) and build” http://jenkins.cloudstack.org/job/build-4.0-rhel63/lastSuccessfulBuild/artifact/CloudStack-oss-4.0.0-363.tar.bz2”

Log :
---------
--------
RAM STATS after allocation: for host: 1, old used: 1312817152, old reserved: 0, total: 8244576256;
new used: 1581252608, reserved: 0; requested mem: 268435456,alloc_from_last:false
2012-10-03 14:03:29,273 DEBUG [agent.transport.Request] (HA-Worker-2:work-6) Seq 7-1550843935:
Waiting for Seq 1550843932 Scheduling:  { Cmd , MgmtId: 6766016331840, via: 7, Ver: v1, Flags:
100111, [{"MigrateCommand":{"vmName":"s-4-VM","destIp":"10.147.40.26","hostGuid":"84145c6b-77a0-3183-8ebc-c8a9ae306448-LibvirtComputingResource","isWindows":false,"wait":0}}]
}
2012-10-03 14:03:29,836 DEBUG [agent.transport.Request] (AgentManager-Handler-12:null) Seq
7-1550843932: Processing:  { Ans: , MgmtId: 6766016331840, via: 7, Ver: v1, Flags: 110, [{"MigrateAnswer":{"result":false,"details":"unable
to set user and group to '0:0' on '/mnt/59119a1e-adb2-32b7-9567-e4d52693e43c/v-3-VM-patchdisk':
No such file or directory","wait":0}}] }
2012-10-03 14:03:29,836 DEBUG [agent.manager.AgentAttache] (AgentManager-Handler-12:null)
Seq 7-1550843933: Sending now.  is current sequence.
2012-10-03 14:03:29,836 DEBUG [agent.transport.Request] (HA-Worker-0:work-5) Seq 7-1550843932:
Received:  { Ans: , MgmtId: 6766016331840, via: 7, Ver: v1, Flags: 110, { MigrateAnswer }
}
2012-10-03 14:03:29,836 ERROR [cloud.vm.VirtualMachineManagerImpl] (HA-Worker-0:work-5) Unable
to migrate due to unable to set user and group to '0:0' on '/mnt/59119a1e-adb2-32b7-9567-e4d52693e43c/v-3-VM-patchdisk':
No such file or directory
2012-10-03 14:03:29,836 INFO  [cloud.vm.VirtualMachineManagerImpl] (HA-Worker-0:work-5) Migration
was unsuccessful.  Cleaning up: VM[ConsoleProxy|v-3-VM]
2012-10-03 14:03:29,843 DEBUG [agent.manager.AgentAttache] (HA-Worker-0:work-5) Seq 1-722599952:
Routed from 6766016331840
2012-10-03 14:03:29,844 DEBUG [agent.transport.Request] (HA-Worker-0:work-5) Seq 1-722599952:
Sending  { Cmd , MgmtId: 6766016331840, via: 1, Ver: v1, Flags: 100111, [{"StopCommand":{"isProxy":false,"vmName":"v-3-VM","wait":0}}]
}

any suggestion how to deal with this problem.
Thanks and Regards
Prashant Kumar Mishra
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message