cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edison Su <Edison...@citrix.com>
Subject RE: Re:Re: maven build error when compile-utils . steps follow cwiki.apache.org's instruction
Date Thu, 13 Sep 2012 01:37:46 GMT
And please use the maven from this repo:
[epel-apache-maven]
name=maven from apache foundation.
baseurl=http://repos.fedorapeople.org/repos/dchen/apache-maven/epel-6Server/$basearch/
enabled=1
skip_if_unavailable=1
gpgcheck=0

I tried on centos 6.2, it works with latest code.
I also tried install maven from jpackage repo, which doesn't work for me.

> -----Original Message-----
> From: yueluck@163.com [mailto:yueluck@163.com] On Behalf Of
> cloudstacks@163.com
> Sent: Wednesday, September 12, 2012 6:41 AM
> To: cloudstack-dev@incubator.apache.org
> Subject: Re:Re: maven build error when compile-utils . steps follow
> cwiki.apache.org's instruction
> 
> yes,latest revision.    i git pull  every day.
> 
> 
> At 2012-09-11 23:40:02,"Wido den Hollander" <wido@widodh.nl> wrote:
> >On 09/11/2012 04:56 PM, coudstacks wrote:
> >> so grieved,never build it correctly.
> >>
> >> mybe the article  lacks something.
> >>
> >> my environment, CentOS Linux release 6.0 .maven 3.0.4.
> >>
> >>   mvn install -P deps
> >>       [exec] [INFO] Building Apache CloudStack Dependencies 4.0.0-
> SNAPSHOT
> >>       [exec] [INFO] ------------------------------------------------
> ------------------------
> >>       [exec] [WARNING] The POM for org.apache.rampart:rampart-
> policy:jar:1.5 is invalid, transitive dependencies (if any) will not be
> available, enable debug logging for more details
> >>       [exec] [WARNING] The POM for org.apache.rampart:rampart-
> trust:jar:1.5 is invalid, transitive dependencies (if any) will not be
> available, enable debug logging for more details
> >>       [exec] [WARNING] The POM for org.apache.axis2:axis2-
> kernel:jar:1.5.1 is invalid, transitive dependencies (if any) will not
> be available, enable debug logging for more details
> >>       [exec] [WARNING] The POM for
> org.apache.axis2:mex:jar:impl:1.5.1 is invalid, transitive dependencies
> (if any) will not be available, enable debug logging for more details
> >>       [exec] [WARNING] The POM for org.apache.axis2:axis2-
> mtompolicy:jar:1.5.1 is invalid, transitive dependencies (if any) will
> not be available, enable debug logging for more details
> >>       [exec] [WARNING] The POM for
> org.apache.ws.security:wss4j:jar:1.5.8 is invalid, transitive
> dependencies (if any) will not be available, enable debug logging for
> more details
> >>       [exec] [WARNING] The POM for opensaml:opensaml:jar:1.1 is
> invalid, transitive dependencies (if any) will not be available, enable
> debug logging for more details
> >>       [exec] [WARNING] The POM for bouncycastle:bcprov-jdk14:jar:140
> is invalid, transitive dependencies (if any) will not be available,
> enable debug logging for more details
> >>       [exec] [INFO]
> >>       [exec] [INFO] --- maven-remote-resources-plugin:1.3:process
> (default) @ cloud-deps ---
> >>       [exec] [WARNING] Invalid POM for org.apache.rampart:rampart-
> policy:jar:1.5, transitive dependencies (if any) will not be available,
> enable debug logging for more details
> >>       [exec] [WARNING] Invalid POM for org.apache.rampart:rampart-
> trust:jar:1.5, transitive dependencies (if any) will not be available,
> enable debug logging for more details
> >>       [exec] [WARNING] Invalid POM for org.apache.axis2:axis2-
> kernel:jar:1.5.1, transitive dependencies (if any) will not be
> available, enable debug logging for more details
> >>       [exec] [WARNING] Invalid POM for
> org.apache.axis2:mex:jar:impl:1.5.1, transitive dependencies (if any)
> will not be available, enable debug logging for more details
> >>       [exec] [WARNING] Invalid POM for org.apache.axis2:axis2-
> mtompolicy:jar:1.5.1, transitive dependencies (if any) will not be
> available, enable debug logging for more details
> >>
> >>
> >>
> >> ant build-all
> >>       [exec] [INFO] ------------------------------------------------
> ------------------------
> >>       [exec] [INFO] BUILD SUCCESS
> >>       [exec] [INFO] ------------------------------------------------
> ------------------------
> >>       [exec] [INFO] Total time: 15.174s
> >>       [exec] [INFO] Finished at: Tue Sep 11 22:21:54 CST 2012
> >>       [exec] [INFO] Final Memory: 17M/52M
> >>       [exec] [INFO] ------------------------------------------------
> ------------------------
> >>
> >> compile-utils:
> >>      [mkdir] Created dir: /mnt/incubator-
> cloudstack/target/classes/cloud-utils.jar
> >>       [echo] Compiling /mnt/incubator-cloudstack/utils/src
> >>      [javac] Compiling 149 source files to /mnt/incubator-
> cloudstack/target/classes/cloud-utils.jar
> >>      [javac] error: error reading /mnt/incubator-
> cloudstack/deps/axis2-mtompolicy-1.5.1.jar; error in opening zip file
> >>      [javac] error: error reading /mnt/incubator-
> cloudstack/deps/bcprov-jdk14-140.jar; error in opening zip file
> >>      [javac] error: error reading /mnt/incubator-
> cloudstack/deps/mex-1.5.1-impl.jar; error in opening zip file
> >>      [javac] 3 errors
> >
> >Do these files exist? And on which branch are you testing?
> >
> >The JAR files you seem to have are outdated. Try on the latest master.
> >
> >Wido
> >
> >>
> >> BUILD FAILED
> >> /mnt/incubator-cloudstack/build/build-cloud.xml:186: The following
> error occurred while executing this line:
> >> /mnt/incubator-cloudstack/build/build-common.xml:65: Compile failed;
> see the compiler error output for details.
> >>
> >> Total time: 19 seconds
> >>
> >

Mime
View raw message