cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject Re: Problem after upgrading to ASF 4.0 RC1
Date Thu, 13 Sep 2012 12:16:20 GMT
Hi,

On 09/13/2012 02:07 PM, Ahmad Saif wrote:
> Hello,
>
> On Classpath.conf :
> jar:/usr/share/java/mysql-connector-java-5.1.21.jar
>
>
> [root@csm ~]# ls -al /usr/share/java/mysql*
> -rw-r--r--. 1 root root 819803 Jun 22 16:33
> /usr/share/java/mysql-connector-java-5.1.17.jar
> lrwxrwxrwx. 1 root root     31 Sep 13 12:59
> /usr/share/java/mysql-connector-java.jar -> mysql-connector-java-5.1.17.jar
>
> So I think I need to update mysql-connector to match the required one,
> right ?
>

I've updated the issue, I'll try to keep it there.

I'll do a commit shortly for the MySQL connector path in the build 
system. The next build should work then.

Wido

>
> On 09/13/2012 01:58 PM, Wido den Hollander wrote:
>> Hello,
>>
>> Could you open /etc/cloud/management/classpath.conf and see if the
>> MySQL connector is listed in there?
>>
>> It's probably looking for a JAR which isn't there.
>>
>> $ ls -al /usr/share/java/mysql*
>>
>> Wido
>>
>> On 09/13/2012 01:53 PM, Ahmad Saif wrote:
>>> Hello Wido,
>>>
>>> I'm upgrading my old cloudstack, so it's already there .., I've also
>>> checked the tomcat version and it's 6.0.24-45
>>>
>>> [root@csm ~]# rpm -aq | grep -i mysql
>>> perl-DBD-MySQL-4.013-3.el6.x86_64
>>> mysql-server-5.1.61-4.el6.x86_64
>>> mysql-5.1.61-4.el6.x86_64
>>> MySQL-python-1.2.3-0.3.c1.1.el6.x86_64
>>> mysql-connector-java-5.1.17-6.el6.noarch
>>> mysql-libs-5.1.61-4.el6.x86_64
>>>
>>> Any other suggestions ?
>>>
>>> Thanks
>>>
>>> On 09/13/2012 01:42 PM, Wido den Hollander wrote:
>>>> Hi,
>>>>
>>>> On 09/13/2012 01:41 PM, Ahmad Saif wrote:
>>>>> Hello there :)
>>>>>
>>>>> Today I've downloaded the last successful artifact form:
>>>>> http://jenkins.cloudstack.org/job/build-cloudstack-4.0-rhel6.3/
>>>>>
>>>>> I've tried to upgrade my existent 3.0.2 cloudstack setup, on the
>>>>> management server after I've upgraded the packages and started the
>>>>> management-server for the first time I encountered this issue :
>>>>>
>>>>> Unexpected exception:
>>>>> java.sql.SQLException: No suitable driver found for
>>>>> jdbc:mysql://localhost:3306/cloud?autoReconnect=true&prepStmtCacheSize=517&cachePrepStmts=true
>>>>>
>>>>>
>>>>>
>>>>
>>>> Do you have the mysql connector installed? It's no longer bundled with
>>>> CS, but has to be installed seperate.
>>>>
>>>> Install the MySQL connector in /usr/share/java, that should be
>>>> sufficient.
>>>>
>>>> Wido
>>>>
>>>>> The full log is attached to my message.
>>>>>
>>>>> Thanks
>>>
>

Mime
View raw message