cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject Re: Failure to find org.libvirt:libvirt:jar:0.4.8 in http://repo1.maven.org/maven2
Date Sat, 08 Sep 2012 20:59:28 GMT


On 08-09-12 21:56, Sebastien Goasguen wrote:
> Hi,
>
> I am trying to build using maven on OSX 10.8.1
> I have maven 3.0.3 installed.
>
> When I do:  mvn -P deps -pl deps
>

Can you try:

$ mvn install -P deps
$ ant build-all

That should work, there is a pom.xml in the KVM hypervisor directory 
which points to libvirt.org for libvirt-java 0.4.8

> I get:
> [ERROR] Failed to execute goal on project cloud-deps: Could not resolve dependencies
for project org.apache.cloudstack:cloud-deps:jar:4.0.0-SNAPSHOT: Failure to find org.libvirt:libvirt:jar:0.4.8
in http://repo1.maven.org/maven2 was cached in the local repository, resolution will not be
reattempted until the update interval of central has elapsed or updates are forced -> [Help
1]
>

Are you sure you have maven 3? I saw my maven connect to repo1 as well, 
but that was when I was using maven 2..

Wido

> I am just trying to get back to ant deploy/debug…
>
> Any thoughts ? thanks,
>
> -Sebastien
>

Mime
View raw message