cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohit Yadav (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-209) Upgrade from CS-3.0.2 to ASF 4.0 fails with com.cloud.utils.exception.CloudRuntimeException: Unable to find key inject script scripts/vm/systemvm/injectkeys.sh
Date Fri, 28 Sep 2012 07:05:07 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-209?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13465439#comment-13465439
] 

Rohit Yadav commented on CLOUDSTACK-209:
----------------------------------------

The issue is when you install 3.0.2, make sure cloud**3.0.2** gets installed. yum will report
trying to install 4.0 version.
There are several issue while upgrading. It's not fully backward compatible. some packages
have been moved, cloud-test is no more in 4.0 (which should be, I don't know), things from
scripts/agent have been moved to /usr/lib64/cloud/common

While upgrading I got this error:
Error: Package: cloud-test-3.0.2-1.el6.x86_64 (installed)
           Requires: cloud-utils = 3.0.2
           Removing: cloud-utils-3.0.2-1.el6.x86_64 (installed)
               cloud-utils = 3.0.2-1.el6
           Updated By: cloud-utils-4.0.0-0.214.el6.4.0.x86_64 (cloud-temp)
               cloud-utils = 4.0.0-0.214.el6.4.0
Error: Package: cloud-test-3.0.2-1.el6.x86_64 (installed)
           Requires: cloud-deps = 3.0.2
           Removing: cloud-deps-3.0.2-1.el6.x86_64 (installed)
               cloud-deps = 3.0.2-1.el6
           Updated By: cloud-deps-4.0.0-0.214.el6.4.0.x86_64 (cloud-temp)
               cloud-deps = 4.0.0-0.214.el6.4.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Done

To fix it, remove cloud-test. Upgrade anecdote: remove cloud-test before upgrading.
While upgrading, it update the new packages and removed old ones while includes cloud-agent-scripts
which removes the files in scripts/vm/systemvm/

  Erasing    : cloud-agent-scripts-3.0.2-1.el6.x86_64                                    
                                                                                         
                        22/23 

Anecdote: Remove and uninstall old 3.0.2 packages before upgrade and install. Or after upgrade,
reinstall, client, client-ui, setup, scripts, etc. once again.

Checkout the upgrade log I got, watch for all the packages that got cleanup, it removes files,
in case they target the same prefix, they will get removed:
Running Transaction
  Updating   : cloud-deps-4.0.0-0.214.el6.4.0.x86_64                                     
                                                                                         
                         1/23 
  Updating   : cloud-utils-4.0.0-0.214.el6.4.0.x86_64                                    
                                                                                         
                         2/23 
  Updating   : cloud-core-4.0.0-0.214.el6.4.0.x86_64                                     
                                                                                         
                         3/23 
  Updating   : cloud-server-4.0.0-0.214.el6.4.0.x86_64                                   
                                                                                         
                         4/23 
  Updating   : cloud-python-4.0.0-0.214.el6.4.0.x86_64                                   
                                                                                         
                         5/23 
  Updating   : cloud-setup-4.0.0-0.214.el6.4.0.x86_64                                    
                                                                                         
                         6/23 
  Installing : cloud-scripts-4.0.0-0.214.el6.4.0.x86_64                                  
                                                                                         
                         7/23 
  Installing : cloud-aws-api-4.0.0-0.214.el6.4.0.x86_64                                  
                                                                                         
                         8/23 
  Updating   : cloud-client-ui-4.0.0-0.214.el6.4.0.x86_64                                
                                                                                         
                         9/23 
  Updating   : cloud-client-4.0.0-0.214.el6.4.0.x86_64                                   
                                                                                         
                        10/23 
  Updating   : cloud-usage-4.0.0-0.214.el6.4.0.x86_64                                    
                                                                                         
                        11/23 
  Updating   : cloud-cli-4.0.0-0.214.el6.4.0.x86_64                                      
                                                                                         
                        12/23 
  Cleanup    : cloud-usage-3.0.2-1.el6.x86_64                                            
                                                                                         
                        13/23 
  Cleanup    : cloud-client-ui-3.0.2-1.el6.x86_64                                        
                                                                                         
                        14/23 
  Cleanup    : cloud-client-3.0.2-1.el6.x86_64                                           
                                                                                         
                        15/23 
Stopping cloud-management:[  OK  ]
  Cleanup    : cloud-setup-3.0.2-1.el6.x86_64                                            
                                                                                         
                        16/23 
  Cleanup    : cloud-server-3.0.2-1.el6.x86_64                                           
                                                                                         
                        17/23 
  Cleanup    : cloud-core-3.0.2-1.el6.x86_64                                             
                                                                                         
                        18/23 
  Cleanup    : cloud-deps-3.0.2-1.el6.x86_64                                             
                                                                                         
                        19/23 
  Cleanup    : cloud-utils-3.0.2-1.el6.x86_64                                            
                                                                                         
                        20/23 
  Cleanup    : cloud-python-3.0.2-1.el6.x86_64                                           
                                                                                         
                        21/23 
  Erasing    : cloud-agent-scripts-3.0.2-1.el6.x86_64                                    
                                                                                         
                        22/23 
  Cleanup    : cloud-cli-3.0.2-1.el6.x86_64                                              
                                                                                         
                        23/23 
Installed products updated.

Installed:
  cloud-scripts.x86_64 0:4.0.0-0.214.el6.4.0                                             
                                                                                         
                              

Dependency Installed:
  cloud-aws-api.x86_64 0:4.0.0-0.214.el6.4.0                                             
                                                                                         
                              

Updated:
  cloud-cli.x86_64 0:4.0.0-0.214.el6.4.0             cloud-client.x86_64 0:4.0.0-0.214.el6.4.0
          cloud-client-ui.x86_64 0:4.0.0-0.214.el6.4.0           cloud-core.x86_64 0:4.0.0-0.214.el6.4.0
          
  cloud-deps.x86_64 0:4.0.0-0.214.el6.4.0            cloud-python.x86_64 0:4.0.0-0.214.el6.4.0
          cloud-server.x86_64 0:4.0.0-0.214.el6.4.0              cloud-setup.x86_64 0:4.0.0-0.214.el6.4.0
         
  cloud-usage.x86_64 0:4.0.0-0.214.el6.4.0           cloud-utils.x86_64 0:4.0.0-0.214.el6.4.0
          

Replaced:
  cloud-agent-scripts.x86_64 0:3.0.2-1.el6                                               
                                                                                         
                              

Complete!
Done

                
> Upgrade from CS-3.0.2 to ASF 4.0 fails with com.cloud.utils.exception.CloudRuntimeException:
Unable to find key inject script scripts/vm/systemvm/injectkeys.sh
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-209
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-209
>             Project: CloudStack
>          Issue Type: Bug
>          Components: Install and Setup, Management Server
>    Affects Versions: pre-4.0.0
>         Environment: MS : Rhel 6.2
> HOST : KVM ( Rhel 6.2)
> BUILDS : 
> CS-3.0.2 - CloudStack-3.0.2-1-rhel6.2.tar.gz
> ASF 4.0 -  CloudStack-oss-4.0.0-187.tar.bz2
>            Reporter: Abhinav Roy
>            Assignee: Wido den Hollander
>            Priority: Blocker
>             Fix For: pre-4.0.0
>
>         Attachments: agent.log, api-server.log, management-server.log, SQL_09_26.dmp
>
>
> Steps :
> ==============================
> 1. Deploy an advanced zone setup with CS-3.0.2 and KVM host (Rhel 6.2)
> 2. Create a VM instance.
> 3. Stop Management server.
> 4. Upgrade to ASF 4.0
> 5. Stop agent services on the host.
> 6. Upgrade to ASF 4.0
> 7. Start agent on the host.
> 8. Start management server services.
> Expected Behaviour :
> ==============================
> The upgrade should happen smoothly without any error.
> Observed Behaviour :
> ==============================
> 1. After executing above steps, following exception is seen in the logs
>     2012-09-26 17:44:41,571 DEBUG [utils.script.Script] (main:null) Looking for scripts/vm/systemvm/injectkeys.sh
in /var/lib/cloud/management/./scripts/vm/systemvm/injectkeys.sh
> 2012-09-26 17:44:41,571 DEBUG [utils.script.Script] (main:null) Looking for scripts/vm/systemvm/injectkeys.sh
in /var/lib/cloud/management/./scripts/vm/systemvm/injectkeys.sh
> 2012-09-26 17:44:41,571 WARN  [utils.script.Script] (main:null) Unable to find script
scripts/vm/systemvm/injectkeys.sh
> 2012-09-26 17:44:41,574 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in the classpath
> 2012-09-26 17:44:41,574 DEBUG [utils.script.Script] (main:null) System resource: null
> 2012-09-26 17:44:41,575 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
> 2012-09-26 17:44:41,575 DEBUG [utils.script.Script] (main:null) Current binaries reside
at /usr/share/java
> 2012-09-26 17:44:41,575 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/share/java/vms/systemvm.iso
> 2012-09-26 17:44:41,575 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/share/java/vms/systemvm.iso
> 2012-09-26 17:44:41,575 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/share/vms/systemvm.iso
> 2012-09-26 17:44:41,576 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/vms/systemvm.iso
> 2012-09-26 17:44:41,576 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /vms/systemvm.iso
> 2012-09-26 17:44:41,576 DEBUG [utils.script.Script] (main:null) Searching in environment.properties
> 2012-09-26 17:44:41,576 DEBUG [utils.script.Script] (main:null) environment.properties
says scripts should be in /usr/lib64/cloud/common
> 2012-09-26 17:44:41,578 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/lib64/cloud/common/vms/systemvm.iso
> 2012-09-26 17:44:41,578 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/lib64/cloud/common/vms/systemvm.iso
> 2012-09-26 17:44:41,578 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/lib64/cloud/vms/systemvm.iso
> 2012-09-26 17:44:41,578 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/lib64/vms/systemvm.iso
> 2012-09-26 17:44:41,578 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/vms/systemvm.iso
> 2012-09-26 17:44:41,578 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /vms/systemvm.iso
> 2012-09-26 17:44:41,578 DEBUG [utils.script.Script] (main:null) Searching in the current
directory
> 2012-09-26 17:44:41,579 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /var/lib/cloud/management/./vms/systemvm.iso
> 2012-09-26 17:44:41,579 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /var/lib/cloud/management/./vms/systemvm.iso
> 2012-09-26 17:44:41,579 WARN  [utils.script.Script] (main:null) Unable to find script
vms/systemvm.iso
> 2012-09-26 17:44:41,582 ERROR [cloud.servlet.CloudStartupServlet] (main:null) Exception
starting management server 
> com.cloud.utils.exception.CloudRuntimeException: Unable to find key inject script scripts/vm/systemvm/injectkeys.sh
>         at com.cloud.server.ConfigurationServerImpl.updateKeyPairs(ConfigurationServerImpl.java:675)
>         at com.cloud.utils.db.DatabaseCallback.intercept(DatabaseCallback.java:34)
>         at com.cloud.server.ConfigurationServerImpl.persistDefaultValues(ConfigurationServerImpl.java:265)
>         at com.cloud.utils.db.DatabaseCallback.intercept(DatabaseCallback.java:34)
>         at com.cloud.servlet.CloudStartupServlet.init(CloudStartupServlet.java:47)
>         at javax.servlet.GenericServlet.init(GenericServlet.java:212)
>         at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
>         at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
>         at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4187)
>         at org.apache.catalina.core.StandardContext.start(StandardContext.java:4496)
>         at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
>         at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
>         at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:526)
>         at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1041)
>         at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:964)
>         at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
>         at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
>         at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
>         at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
>         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
>         at org.apache.catalina.core.StandardHost.start(StandardHost.java:722)
>         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
>         at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
>         at org.apache.catalina.core.StandardService.start(StandardService.java:516)
>         at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
>         at org.apache.catalina.startup.Catalina.start(Catalina.java:593)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:616)
>         at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
>         at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
> 2. This exception I feel is because of the change in script paths recently and is independent
of the host hypervisor.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message