cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <>
Subject CloudStack 4.0 KVM system requirements
Date Thu, 02 Aug 2012 12:57:56 GMT

As we are working our way towards CS 4.0 I think we should set some 
system requirements.

My experience with other Hypervisors than KVM is limited, I'd like to 
keep this discussion limited to the KVM Hypervisors.

What platforms are we going to support?

The reason I'm asking that I still have a couple of things I want to 
fix, but they require at least libvirt 0.9.0

Ubuntu 10.04 and RHEL/CentOS 5 ship with an ancient version of libvirt.

Ubuntu 12.04 has 0.9.8 and CentOS 6.3 has 0.9.10 while CentOS 6.2 has 
0.9.4. CentOS 6.1 has 0.8.7 though.

Are we going to set the requirement that the hypervisor should be at 
least Ubuntu 12.04 or CentOS 6.2?

This way we know that we will be working with at least libvirt 0.9.4 
which has a lot more features then <0.9.0 did.

New features:
- disk I/O tuning
- More/better CPU scheduling

The exception will however be that when you want to use RBD you need at 
least 0.10.0 (due to come out in a couple of days), but that's a 
specific use-case for new users.

Can we set this requirement for users who want to upgrade their KVM 


View raw message