cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nalley <da...@gnsa.us>
Subject Re: [RFC] DevCloud, an all-in-one-box CloudStack development environment
Date Mon, 09 Jul 2012 02:23:13 GMT
On Sun, Jul 8, 2012 at 8:20 PM, Edison Su <Edison.su@citrix.com> wrote:
>
>
> Sent from my iPhone
>
> On Jul 7, 2012, at 9:19 AM, "Tomoe Sugihara" <tomoe@midokura.com<mailto:tomoe@midokura.com>>
wrote:
>
> Hi Edison,
>
> This is very helpful for newbies like me.
> However, I tried this according to the wiki page, but found some problems listed below.
> I managed to add a host, but couldn't even launch a VM due to the issue 3.
>
> I hope this would help improve DevCloud.
>
> ----------------------------
> 1. ssh commands failed
>
>    I got "com.jcraft.jsch.JSchException: reject HostKey" when I tried some ant r* targets.
>    So, I worked around this with the patch attached.
> Thanks for your patch, but could please post the patch here? Attached is not allowed
in apache mailing list.

So it's expecting that you have sshed into the host first. (and it
makes a difference which address) By default it will try and connect
on localhost port 2222. So start by sshing manually to the host,
should work after that.


>
> 2. rdeploydb didn't work
>
>   Since many scripts uses --password option to pass in password and mysql prompts you,
many of the commands failed.
>
>   I ended up ssh'ing to dom0 and did the equivalent db setup.
>
> Possible reason: do you override dbrootpw in build/override/replace.properties on your
host CloudStack source code directory? If it's been override, then rdeploydb will use $dbrootpw
to deploy devcloud db, while devcloud db password is empty, so then failed.

Edison: with a fresh clone I am getting:
[sshexec]      [exec] failed to init cloudev dbERROR 1045 (28000):
Access denied for user 'cloud'@'localhost' (using password: YES)

I looked and it's passing --password="password".
I fixed this in commit f157b702e4c6821fc4af4c27e085dea097b79101 and
that gets me further, but it's still broken

[sshexec] deploy-cloudstack-db:
  [sshexec]      [echo] deploydb server-setup.xml templates.sql ${DBROOTPW}
  [sshexec]      [exec] Recreating Database cloud.
  [sshexec]
  [sshexec]      [exec] Please enter root password for MySQL.
  [sshexec]
  [sshexec]      [exec] Error: Cannot execute create-database.sql
  [sshexec]
  [sshexec]      [exec] Enter password: ERROR 1045 (28000): Access
denied for user 'root'@'localhost' (using password: YES)
  [sshexec]
  [sshexec]      [exec] Result: 10
  [sshexec]


And similar issues with awsapi - I'll continue playing with it tonight
and try and fix it.



>
> 3. tiny Linux template is not in good status
>
>  Status says "Unable to resolve nfs1.lab.vmops.com<http://nfs1.lab.vmops.com>"...
>
>  Is there any place from which I can download templates easily?
> You don't need to download this template, it's already preinstalled on devcloud image,
it's put under /opt/storage/secondary/template/tmpl/1/5/.
> After secondary storage vm booting up, it will report this template to mgt server.
> Can you stop/start secondary storage vm? And check the management server log(/opt/cloudstack/incu*/vmops.log,
search ListTemplate. What ListTemplate returns?

Incidentally doesn't show up in mine either, and sysVMs aren't
starting, I wanted to push new code up more than I wanted to start
VMs, so I haven't gotten to play with this yet.

Mime
View raw message