cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tommy Aditya Lawanto <to...@wowrack.com>
Subject RE: Fail to get password for VM using API
Date Tue, 31 Jul 2012 07:29:33 GMT
@alena : thank you very much for your help :). I tried to set keypair when deploying a vm,
but it returns error message : A key pair with name 'my-generated-string' was not found. Am
i supposed to do something first for this ssh keypair ? (i try supplying "ssh keypair" value
with my auto-generated-string.

Sorry for the noob question, i'm a newbie in the cloud computing environment :)

________________________________________
From: Alena Prokharchyk [Alena.Prokharchyk@citrix.com]
Sent: Monday, July 30, 2012 11:35 PM
To: cloudstack-dev@incubator.apache.org
Subject: Re: Fail to get password for VM using API

On 7/29/12 9:31 PM, "Tommy Aditya Lawanto" <tommy@wowrack.com> wrote:

>I'm getting this error when i try to get password from a vm using
>password-enabled template (through API) :
>
>
> [error] => No password for VM with id '70' found.
>
>
>I've tried resetting the password using management server, and it works
>fine. Right after the operation successful, a message box popped up,
>giving me the new password. However, when i try get the password using
>API command "getVMPassword", it always fail.
>
>
>How can I fix it?
>
>
>Best Regard !
>



Tommy,

The password is getting stored in the DB only when the user vm is deployed
using SshKeyPair. So only in this case you can use getVMPassword api to
retrieve the password. I'll make sure the documentation is updated for
this command in the future release.

In your case, if you forgot the password returned to you on the
confirmation box, you can always reset it using
resetPasswordForVirtualMachine API

-Alena.



Mime
View raw message