cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Nalley" <da...@gnsa.us>
Subject Re: Review Request: fix for broken attachVolume command
Date Sat, 14 Jul 2012 22:12:12 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/5834/#review9157
-----------------------------------------------------------


Hugo, would you mind filing a bug for this along with the output from the NPE

- David Nalley


On July 9, 2012, 12:45 p.m., Hugo Trippaers wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/5834/
> -----------------------------------------------------------
> 
> (Updated July 9, 2012, 12:45 p.m.)
> 
> 
> Review request for cloudstack.
> 
> 
> Description
> -------
> 
> attachVolume is broken as a call to this command will result in a NPE. The cause appears
to be that _hostVolumeDao is null during execution. The root cause is that the HostVolumeDao
is missing the @Inject annotation.
> 
> 
> Diffs
> -----
> 
>   server/src/com/cloud/vm/UserVmManagerImpl.java 87d88a4 
> 
> Diff: https://reviews.apache.org/r/5834/diff/
> 
> 
> Testing
> -------
> 
> clean-all build-all deploy-server
> 
> create volume and attach to existing host.. success
> 
> 
> Thanks,
> 
> Hugo Trippaers
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message