cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sheng Yang <sh...@yasker.org>
Subject Re: HA at KVM cluster on CloudStack 3.0.1
Date Mon, 07 May 2012 22:47:00 GMT
On Mon, May 7, 2012 at 2:13 AM, 北川 大輔 <daisuke.kitagawa@inte.co.jp> wrote:
> Hi All!
>
> I still have problem  I had a while ago...
>
>> Right after putting primary host to maintenance mode, all vm forced stop. You would
find it in a log files.
>
> Do anyone have same problem putting KVM to maintenance mode?
>
> Thank you for your time.

Hi Daitsuke,

This issue should be fixed by Prachi at:

commit 58ac2420b3d7acb4b61029fbba5b323939c5315c
Author: prachi <prachi@cloud.com>
Date:   Wed Apr 11 16:15:19 2012 -0700

    Bug 14646 - Enabling Host into maintenance mode is stopping the
VMs instead of live migrating them to other hosts in the cluster.

    Changes:
    -  While listing UP hosts in the cluster of the host, the query
has changed and now also considers the Host 'resourceState' field and
picks only those hosts
       This query result does not include the host being put in
maintainance; unlike the earlier query that used to include it.
    -  But the logic to find out if this is the last host in the
Cluster is not updated and has a bug when it compares the list size.
    - Fixed this

The fix would be in 3.0.2 release.

--
regards
Yang, Sheng

>
> -----Original Message-----
> From: 北川 大輔 [mailto:daisuke.kitagawa@inte.co.jp]
> Sent: Tuesday, April 24, 2012 2:25 PM
> To: Abhinandan Prateek; cloudstack-dev@incubator.apache.org
> Subject: RE: HA at KVM cluster on CloudStack 3.0.1
>
> Hi Abhinandan!
>
> There are two log files and two screen captured images.
> I have captured them while the live migration failure.
> And you would see how all the VM stops.
>
> Right after putting primary host to maintenance mode, all vm forced stop. You would find
it in a log files.
>
> Thank you.
>
> --
> Daisuke kitagawa
>
> Intelligence Business Solutions
>
> 1-4-4 Yanagibashi Taito-ku
> Tokyo-to Japan  111-0052
> Phone: +81 3 6385 6103
> FAX: +81 3 6385 6104
>
> http://ibs.inte.co.jp/
>
> -----Original Message-----
> From: Abhinandan Prateek [mailto:Abhinandan.Prateek@citrix.com]
> Sent: Monday, April 23, 2012 8:12 PM
> To: cloudstack-dev@incubator.apache.org; 北川 大輔
> Subject: RE: HA at KVM cluster on CloudStack 3.0.1
>
> Hi Daisuke kitagawa,
>  Will it be possible to send us management server logs when you put the host to maintenance
and saw your VMs getting stopped.
> Thanks,
> -Abhi
>
> -----Original Message-----
> From: 北川 大輔 [mailto:]
> Sent: Monday, April 23, 2012 12:57 PM
> To: cloudstack-dev@incubator.apache.org
> Subject: HA at KVM cluster on CloudStack 3.0.1
>
> Hello everyone!
>
> There is a problem processing live migration using CloudStack 3.0.1 on KVM.
> I have exactly same problem as question posted to CloudStack user/admin discussions.
>
> Frank told that this was known issue, yet it was fixed in previous version.
> As far as I know, live migration worked on CloudStack 3.0.0 Bata. And never be tested
on CloudStack 3.0.0 myself.
>
> Is there are anyone had same experience and solved it?
> I do not see any error or exception on cloud-management.log and api-server.log.  I might
be checking wrong logs?
>
>> Hi all. I have kvm cluster with 2 hosts.
>> Cloudstack version 3.0.0
>> I run instance with HA enabled:
>> 1)            Manual migration to another host work good
>> 2)            When I kill instance process at hosts. HA successfully restart
instance.
>> 3)            When I put host to maintenance mode, system VMs migrate to another
host, but my instance  stopped and that’s all.
>
> http://sourceforge.net/mailarchive/forum.php?forum_name=cloudstack-users&max_rows=25&style=nested&viewmonth=201204&viewday=23
>
> Thank you!
>
> --
> Daisuke kitagawa
>
> Intelligence Business Solutions
>
> 1-4-4 Yanagibashi Taito-ku
> Tokyo-to Japan  111-0052
> Phone: +81 3 6385 6103
> FAX: +81 3 6385 6104
>
> http://ibs.inte.co.jp/



-- 
regards
Yang, Sheng

Mime
View raw message