cloudstack-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [cloudstack] richardlawley opened a new issue #3461: guest_os_hypervisor missing entries for XenServer 7.1.2
Date Wed, 03 Jul 2019 10:40:42 GMT
richardlawley opened a new issue #3461: guest_os_hypervisor missing entries for XenServer 7.1.2
URL: https://github.com/apache/cloudstack/issues/3461
 
 
   <!--
   Verify first that your issue/request is not already reported on GitHub.
   Also test if the latest release and master branch are affected too.
   Always add information AFTER of these HTML comments, but no need to delete the comments.
   -->
   
   ##### ISSUE TYPE
   <!-- Pick one below and delete the rest -->
    * Bug Report
   
   ##### COMPONENT NAME
   <!--
   Categorize the issue, e.g. API, VR, VPN, UI, etc.
   -->
   ~~~
   DB
   ~~~
   
   ##### CLOUDSTACK VERSION
   <!--
   New line separated list of affected versions, commit ID for issues on master branch.
   -->
   
   ~~~
   4.11.2, 4.11.3
   ~~~
   
   ##### CONFIGURATION
   <!--
   Information about the configuration if relevant, e.g. basic network, advanced networking,
etc.  N/A otherwise
   -->
   N/A
   
   ##### OS / ENVIRONMENT
   <!--
   Information about the environment if relevant, N/A otherwise
   -->
   XenServer 7.1.2 (7.1 CU2) Hosts
   
   ##### SUMMARY
   <!-- Explain the problem/feature briefly -->
   There are no entries in guest_os_hypervisor for XenServer 7.1 CU2 (the current LTS XenServer)
which means guests are booted using the "Other Install Media" template.  Amongst other things,
this means that PV guests boot as HV, but also likely means guests won't get XenServer optimisations
for their OS type.
   
   Perhaps a better way rather than just inserting specific rows for this version would be
to add logic to ignore the revision number in a version matching pattern x.y.z if there are
no rows found, e.g. look for row with version = 7.1.2, fallback to row with version = 7.1.0
(would still work if XenServer is updated without CloudStack being updated).
   
   Related: #3086
   
   ##### STEPS TO REPRODUCE
   <!--
   For bugs, show exactly how to reproduce the problem, using a minimal test-case. Use Screenshots
if accurate.
   
   For new features, show how the feature would be used.
   -->
   Install Fresh CloudStack instance with new XenServer 7.1.2 hosts.  Wait for CS to try to
deploy system VMs.
   
   <!-- Paste example playbooks or commands between quotes below -->
   ~~~
   
   ~~~
   
   <!-- You can also paste gist.github.com links for larger files -->
   
   ##### EXPECTED RESULTS
   <!-- What did you expect to happen when running the steps above? -->
   System VMs should boot using the Debian Wheezy 7.0 (64-bit) XenServer template
   
   ~~~
   
   ~~~
   
   ##### ACTUAL RESULTS
   <!-- What actually happened? -->
   System VMs should boot using the Other Install Media XenServer template (which fails to
boot in a virtual environment using XenServer running on VMs, only capable of running PV).
   
   <!-- Paste verbatim command output between quotes below -->
   ~~~
   
   ~~~
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message