cloudstack-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From seb...@apache.org
Subject [2/2] git commit: updated formatting to be consistent with the rest of the docs: This closes #14
Date Thu, 29 May 2014 15:56:36 GMT
updated formatting to be consistent with the rest of the docs: This closes #14

Signed-off-by: Sebastien Goasguen <runseb@gmail.com>


Project: http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/repo
Commit: http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/commit/32bd4fb8
Tree: http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/tree/32bd4fb8
Diff: http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/diff/32bd4fb8

Branch: refs/heads/master
Commit: 32bd4fb8ccd7272627884ff0fb47c1dfd3a09896
Parents: 0562e14
Author: Will Stevens <wstevens@cloudops.com>
Authored: Thu May 29 11:48:17 2014 -0400
Committer: Sebastien Goasguen <runseb@gmail.com>
Committed: Thu May 29 17:56:00 2014 +0200

----------------------------------------------------------------------
 source/about.rst                    |  97 +++++++----
 source/api-changes.rst              |   3 +-
 source/compat.rst                   |  41 +++--
 source/fixed_issues.rst             |  14 +-
 source/global.rst                   |   4 +-
 source/index.rst                    |  23 ++-
 source/known_issues.rst             |  10 +-
 source/upgrade/_sysvm_restart.rst   |  50 +++---
 source/upgrade/_sysvm_templates.rst | 169 +++++++++----------
 source/upgrade/_upgrade_header.rst  |  10 +-
 source/upgrade/upgrade-2.2.14.rst   | 275 +++++++++++++++++--------------
 source/upgrade/upgrade-3.0.x.rst    | 192 ++++++++++++---------
 source/upgrade/upgrade-4.0.rst      |  80 ++++++---
 source/upgrade/upgrade-4.1.rst      | 133 +++++++++------
 source/upgrade/upgrade-4.2.rst      | 157 +++++++++++-------
 source/upgrade/upgrade-4.3.rst      | 136 ++++++++-------
 source/upgrade/upgrade_notes.rst    |  15 +-
 source/upgrade/valid_source.rst     |  73 +++-----
 18 files changed, 852 insertions(+), 630 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/about.rst
----------------------------------------------------------------------
diff --git a/source/about.rst b/source/about.rst
index 23d1adc..904e0a4 100644
--- a/source/about.rst
+++ b/source/about.rst
@@ -15,87 +15,114 @@
    
 
 What's New in |version|
-#######################
+=======================
 
 CloudStack |version| includes the following new features and improvements.
 
 
 Support managed storage for root disks
-======================================
+--------------------------------------
 
-   Use of Primary Storage Plug-in for Root disks. See `Configuring a Storage Plug-in <http://docs.cloudstack.apache.org/projects/cloudstack-    installation/en/master/configuration.html#configuring-a-storage-plug-in>`_
+   Use of Primary Storage Plug-in for Root disks. See `Configuring a Storage Plug-in 
+   <http://docs.cloudstack.apache.org/projects/cloudstack-installation/en/master/configuration.html#configuring-a-storage-plug-in>`_
       
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
    Supported hypervisors: XenServer, VMware
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
 
 
 Root disk resize
-======================================
+----------------
 
-   Allow Root disk resize which remove need to have multiple templates of the same Operating System for different disk size.
+   Allow Root disk resize which remove need to have multiple templates of the 
+   same Operating System for different disk size.
    
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
    Supported hypervisor:  KVM
    Link                   `Root resize Functional spec`_
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
 
 
 Per primary Storage OverProvisioning
-======================================
+------------------------------------
 
-   Added per Primary Storage ``storage.overprovisioning.factor`` setting to overseed the Global Settings value.
+   Added per Primary Storage ``storage.overprovisioning.factor`` setting to 
+   overseed the Global Settings value.
    
-   - admin can update an existing primary store by setting ``storage.overprovisioning.factor`` in the per primary setting.
-   - This value will override the value at the global level. This leverages the granularity of global parameters introduced in 4.2
-   - To fall back to the global value, null value can be passed.
-   - To disable overprovision a value of 1 will be passed.
+   -  admin can update an existing primary store by setting 
+      ``storage.overprovisioning.factor`` in the per primary setting.
+   
+   -  This value will override the value at the global level. This leverages 
+      the granularity of global parameters introduced in 4.2
+   
+   -  To fall back to the global value, null value can be passed.
+   
+   -  To disable overprovision a value of 1 will be passed.
  
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
    Supported hypervisor:  KVM
    link                   `Storage Over Prov. Functional spec`_
-   ====================== ===========================================================================================================
-
-   
-
+   ====================== ============================================================================
 
 
 VMWare Support for DRS
-======================================
+----------------------
 
-   VMware DRS(Distributed Resource Scheduler), VM HA(High Availability): Provide highly available resources to your workloads. Balance    workloads for optimal performance. Scale and manage computing resources without service disruption.
+   VMware DRS(Distributed Resource Scheduler), VM HA(High Availability): 
+   Provide highly available resources to your workloads. Balance workloads for 
+   optimal performance. Scale and manage computing resources without service 
+   disruption.
+   
+   -  **Load Balancing**: distribution and usage of CPU and memory resources 
+      for all hosts and VMs in the cluster are continuously monitored and 
+      compared to ideal resource utilization given the attributes of the 
+      cluster’s resource pools and VMs, the current demand, and the imbalance 
+      target. It then performs (or recommends) virtual machine migrations 
+      accordingly. Also, when a VM is powered on in the cluster, DRS attempts 
+      to maintain proper load balancing by either placing the VM on an 
+      appropriate host or making a recommendation.
    
-   - **Load Balancing**: distribution and usage of CPU and memory resources for all hosts and VMs in the cluster are continuously monitored  and compared to ideal resource utilization given the attributes of the cluster’s resource pools and VMs, the current demand, and the    imbalance target. It then performs (or recommends) virtual machine migrations accordingly. Also, when a VM is powered on in the cluster,  DRS attempts to maintain proper load balancing by either placing the VM on an appropriate host or making a recommendation.
-   - **Power Management**: When the vSphere Distributed Power Management (DPM) feature is enabled, DRS compares cluster- and host-level   capacity to the demands of the cluster’s VMs, including recent historical demand. It places (or recommends placing) hosts in standby  power mode if sufficient excess capacity is found or powering on hosts if capacity is needed. Depending on the resulting host power state  recommendations, VMs might need to be migrated to and from the hosts as well.
-   - **Affinity Rules**: control the placement of virtual machines on hosts within a cluster, by assigning affinity rules 
+   -  **Power Management**: When the vSphere Distributed Power Management 
+      (DPM) feature is enabled, DRS compares cluster- and host-level capacity 
+      to the demands of the cluster’s VMs, including recent historical demand. 
+      It places (or recommends placing) hosts in standby  power mode if 
+      sufficient excess capacity is found or powering on hosts if capacity is 
+      needed. Depending on the resulting host power state  recommendations, 
+      VMs might need to be migrated to and from the hosts as well.
    
-   ====================== ===========================================================================================================
+   -  **Affinity Rules**: control the placement of virtual machines on hosts 
+      within a cluster, by assigning affinity rules 
+   
+   ====================== ============================================================================
    Supported hypervisors: VMware
    Link                   `DRS Functional spec`_
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
 
 
 Zone Wide Primary Store in Hyper-V
-======================================
+----------------------------------
 
    SMB share as zone wide primary storage.
 
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
    Supported hypervisors: Hyper-V
    Link                   
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
+
 
 CloudStack on Windows
-======================================
+---------------------
 
-   Windowsfication of CloudStack Management Server, remove dependency on cygwin in order to run CloudStack Management Server on Windows   based Operating System.
+   Windowsfication of CloudStack Management Server, remove dependency on 
+   cygwin in order to run CloudStack Management Server on Windows based 
+   Operating System.
    
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
    Supported hypervisors: N/A
    Link                   `CLOUDSTACK-6105 <https://issues.apache.org/jira/browse/CLOUDSTACK-6105>`_
-   ====================== ===========================================================================================================
+   ====================== ============================================================================
    
 
 .. _Storage Over Prov. Functional spec: https://cwiki.apache.org/confluence/display/CLOUDSTACK/Storage+OverProvisioning+as+Per+Primary+Basis
 .. _Root resize Functional spec: https://cwiki.apache.org/confluence/display/CLOUDSTACK/Root+Resize+Support
-.. _DRS Functional spec: https://cwiki.apache.org/confluence/display/CLOUDSTACK/VMWare+Enhancements+-+Support+for+DRS+and+VM+HA
\ No newline at end of file
+.. _DRS Functional spec: https://cwiki.apache.org/confluence/display/CLOUDSTACK/VMWare+Enhancements+-+Support+for+DRS+and+VM+HA

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/api-changes.rst
----------------------------------------------------------------------
diff --git a/source/api-changes.rst b/source/api-changes.rst
index d34b718..f6e1546 100644
--- a/source/api-changes.rst
+++ b/source/api-changes.rst
@@ -12,7 +12,8 @@
    KIND, either express or implied.  See the License for the
    specific language governing permissions and limitations
    under the License.
-   
+
+
 API Changes Introduced in |version|
 ===================================
 

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/compat.rst
----------------------------------------------------------------------
diff --git a/source/compat.rst b/source/compat.rst
index c01b0b2..6fec50f 100644
--- a/source/compat.rst
+++ b/source/compat.rst
@@ -12,7 +12,8 @@
    KIND, either express or implied.  See the License for the
    specific language governing permissions and limitations
    under the License.
-   
+
+
 Compatibility Matrix
 ====================
 
@@ -27,13 +28,18 @@ platforms listed below are the ones that are specifically tested against
 and are more likely to be able to help troubleshoot if you run into any
 issues.
 
-.. note:: that specific versions of the operating systems are tested, so compatibility with CentOS 6.3 may not
-          indicate compatibility with CentOS 6.2, 6.1 and so on.
+.. note:: 
+   That specific versions of the operating systems are tested, so 
+   compatibility with CentOS 6.3 may not indicate compatibility with CentOS 
+   6.2, 6.1 and so on.
+
+-  CentOS versions 6.5 (32 and 64 bit)
 
-- CentOS versions 6.5 (32 and 64 bit)
-- FreeBSD 10 (32 and 64 bit)
-- Microsoft Winows 8.1 (32 and 64 bit)
-- Windows XP SP3 (32 and 64 bit)
+-  FreeBSD 10 (32 and 64 bit)
+
+-  Microsoft Winows 8.1 (32 and 64 bit)
+
+-  Windows XP SP3 (32 and 64 bit)
 
 
 Supported Hypervisor Versions
@@ -41,7 +47,9 @@ Supported Hypervisor Versions
 
 No new supported hypervisors in |version|.
 
-For more information, see the Hypervisor Compatibility Matrix in the `CloudStack Installation Guide`_.
+For more information, see the Hypervisor Compatibility Matrix in the 
+`CloudStack Installation Guide`_.
+
 
 Supported External Devices
 --------------------------
@@ -59,21 +67,12 @@ browser, but it's possible that some browsers will not render portions
 of the UI reliably, depending on their support of Web standards. For
 best results, one of the following browsers recommended:
 
--  
-
-   Internet Explorer versions 10 and 11
-
--  
-
-   Firefox version 26 or lower
-
--  
-
-   Google Chrome version 31
+-  Internet Explorer versions 10 and 11
 
--  
+-  Firefox version 26 or lower
 
-   Safari 5
+-  Google Chrome version 31
 
+-  Safari 5
 
 .. include:: global.rst

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/fixed_issues.rst
----------------------------------------------------------------------
diff --git a/source/fixed_issues.rst b/source/fixed_issues.rst
index 877c3a0..5a864a8 100644
--- a/source/fixed_issues.rst
+++ b/source/fixed_issues.rst
@@ -12,14 +12,18 @@
    KIND, either express or implied.  See the License for the
    specific language governing permissions and limitations
    under the License.
-   
+
+
 Issues Fixed in |release|
 -------------------------
 
-Apache CloudStack uses `Jira <https://issues.apache.org/jira/browse/CLOUDSTACK>`_ to track its
-issues. All new features and bugs for |release| have been tracked in Jira, and have a standard naming convention of "CLOUDSTACK-NNNN" where "NNNN" is the issue number.
+Apache CloudStack uses `Jira <https://issues.apache.org/jira/browse/CLOUDSTACK>`_ 
+to track its issues. All new features and bugs for |release| have been tracked 
+in Jira, and have a standard naming convention of "CLOUDSTACK-NNNN" where 
+"NNNN" is the issue number.
 
-For the list of issues fixed, see `Issues Fixed in <https://issues.apache.org/jira/issues/?filter=12327096>`_ |release|.
+For the list of issues fixed, see `Issues Fixed in 
+<https://issues.apache.org/jira/issues/?filter=12327096>`_ |release|.
 
 ==========================================================================  ===================================================================================
 Bug ID                                                                      Description
@@ -122,4 +126,4 @@ Bug ID                                                                      Desc
 `CLOUDSTACK-2714 <https://issues.apache.org/jira/browse/CLOUDSTACK-2714>`_  Setting tab should not be visible for user accounts ...
 `CLOUDSTACK-2697 <https://issues.apache.org/jira/browse/CLOUDSTACK-2697>`_  cluster id in alert message is null {alertType:: 1 // dataCenterId:: 1 // podId:...
 `CLOUDSTACK-2031 <https://issues.apache.org/jira/browse/CLOUDSTACK-2031>`_  [mipn] support for number of ips per nic limit needs to be added for the multipl...
-==========================================================================  ===================================================================================
\ No newline at end of file
+==========================================================================  ===================================================================================

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/global.rst
----------------------------------------------------------------------
diff --git a/source/global.rst b/source/global.rst
index b1b1976..4ba928d 100644
--- a/source/global.rst
+++ b/source/global.rst
@@ -12,12 +12,14 @@
    KIND, either express or implied.  See the License for the
    specific language governing permissions and limitations
    under the License.
-   
+
+
 .. This file contain Variables shared across .rst files in this project
 
 .. _CloudStack Installation Guide: http://docs.cloudstack.apache.org/projects/cloudstack-installation
 .. _CloudStack Administrator's Guide: http://docs.cloudstack.apache.org/projects/cloudstack-administration
 
+
 .. |sysvm-url-xen| replace:: http://jenkins.buildacloud.org/view/4.4/job/cloudstack-4.4-systemvm/lastSuccessfulBuild/artifact/tools/appliance/dist/systemvmtemplate-master-xen.vhd.bz2
 .. |sysvm-url-kvm| replace:: http://jenkins.buildacloud.org/view/4.4/job/cloudstack-4.4-systemvm/lastSuccessfulBuild/artifact/tools/appliance/dist/systemvmtemplate-master-kvm.qcow2.bz2
 .. |sysvm-url-vmware| replace:: http://jenkins.buildacloud.org/view/4.4/job/cloudstack-4.4-systemvm/lastSuccessfulBuild/artifact/tools/appliance/dist/systemvmtemplate-master-vmware.ova

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/index.rst
----------------------------------------------------------------------
diff --git a/source/index.rst b/source/index.rst
index 71027e9..3553d4a 100644
--- a/source/index.rst
+++ b/source/index.rst
@@ -18,16 +18,23 @@
    You can adapt this file completely to your liking, but it should at least
    contain the root `toctree` directive.
 
+
 Welcome to Apache CloudStack Release Notes
 ==========================================
 
 .. figure:: /_static/images/acslogo.png
-    :align: center
+   :align: center
 
-.. warning:: We are in the process of changing documentation format as well as hosting mechanism.
-             Please be patient with us as we migrate our entire documentation to this new setup.
+.. warning:: 
+   We are in the process of changing documentation format as well as hosting 
+   mechanism. Please be patient with us as we migrate our entire documentation 
+   to this new setup.
 
-This document contains information specific to this release of CloudStack, including upgrade instructions from prior releases, new features added to CloudStack, API changes, and issues fixed in the release. For installation instructions, please see the `CloudStack Installation Guide`_. For usage and administration instructions, please see the `CloudStack Administrator's Guide`_.
+This document contains information specific to this release of CloudStack, 
+including upgrade instructions from prior releases, new features added to 
+CloudStack, API changes, and issues fixed in the release. For installation 
+instructions, please see the `CloudStack Installation Guide`_. For usage and 
+administration instructions, please see the `CloudStack Administrator's Guide`_.
 
 
 Contents:
@@ -37,30 +44,37 @@ Contents:
 
    about
 
+
 .. toctree::
    :maxdepth: 2
 
    fixed_issues
 
+
 .. toctree::
    :maxdepth: 2
 
    compat
+   
+
 .. toctree::
    :maxdepth: 2
 
    api-changes
 
+
 .. toctree::
    :maxdepth: 2
 
    known_issues   
 
+
 .. toctree::
    :maxdepth: 2
 
    upgrade/upgrade_notes
 
+
 .. toctree::
    :maxdepth: 1
 
@@ -72,4 +86,5 @@ Contents:
    upgrade/upgrade-2.2.14
    upgrade/valid_source
    
+   
 .. include:: global.rst

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/known_issues.rst
----------------------------------------------------------------------
diff --git a/source/known_issues.rst b/source/known_issues.rst
index 0281510..d30e1e8 100644
--- a/source/known_issues.rst
+++ b/source/known_issues.rst
@@ -13,12 +13,18 @@
    specific language governing permissions and limitations
    under the License.
 
+
 Known Issues in |release|
 -------------------------
 
-Apache CloudStack uses `Jira <https://issues.apache.org/jira/browse/CLOUDSTACK>`_ to track its issues. All new features and bugs for |release| have been tracked in Jira, and have a standard naming convention of "CLOUDSTACK-NNNN" where "NNNN" is the issue number.
+Apache CloudStack uses `Jira 
+<https://issues.apache.org/jira/browse/CLOUDSTACK>`_ to track its issues. All 
+new features and bugs for |release| have been tracked in Jira, and have a 
+standard naming convention of "CLOUDSTACK-NNNN" where "NNNN" is the issue 
+number.
 
-For the list of known issues, see `Known Issues in <https://issues.apache.org/jira/issues/?filter=12327097>`_ |release|.
+For the list of known issues, see `Known Issues in 
+<https://issues.apache.org/jira/issues/?filter=12327097>`_ |release|.
 
 ==========================================================================  ===================================================================================
 Bug ID                                                                      Description

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/upgrade/_sysvm_restart.rst
----------------------------------------------------------------------
diff --git a/source/upgrade/_sysvm_restart.rst b/source/upgrade/_sysvm_restart.rst
index 2b390a1..24f7495 100644
--- a/source/upgrade/_sysvm_restart.rst
+++ b/source/upgrade/_sysvm_restart.rst
@@ -1,3 +1,19 @@
+.. Licensed to the Apache Software Foundation (ASF) under one
+   or more contributor license agreements.  See the NOTICE file
+   distributed with this work for additional information#
+   regarding copyright ownership.  The ASF licenses this file
+   to you under the Apache License, Version 2.0 (the
+   "License"); you may not use this file except in compliance
+   with the License.  You may obtain a copy of the License at
+   http://www.apache.org/licenses/LICENSE-2.0
+   Unless required by applicable law or agreed to in writing,
+   software distributed under the License is distributed on an
+   "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+   KIND, either express or implied.  See the License for the
+   specific language governing permissions and limitations
+   under the License.
+
+
 System-VMs and Virtual-Routers
 ------------------------------
 
@@ -6,7 +22,8 @@ need to restart the system VMs. Ensure that the admin port is set to
 8096 by using the "integration.api.port" global parameter. This port
 is used by the cloud-sysvmadm script at the end of the upgrade
 procedure. For information about how to set this parameter, see
-`Setting Global Configuration Parameters <http://docs.cloudstack.apache.org/projects/cloudstack-installation/en/latest/configuration.html#setting-global-configuration-parameters>`_ in the Installation Guide.
+`Setting Global Configuration Parameters 
+<http://docs.cloudstack.apache.org/projects/cloudstack-installation/en/latest/configuration.html#setting-global-configuration-parameters>`_ in the Installation Guide.
 Changing this parameter will require management server restart. Also
 make sure port 8096 is open in your local host firewall to do this.
 
@@ -16,39 +33,24 @@ your MySQL credentials:
 
 .. sourcecode:: bash
 
-    # nohup cloudstack-sysvmadm -d IP address -u cloud -p -a > sysvm.log 2>&1 &
+   # nohup cloudstack-sysvmadm -d IP address -u cloud -p -a > sysvm.log 2>&1 &
 
 You can monitor the log for progress. The process of restarting the
 system VMs can take an hour or more.
 
 .. sourcecode:: bash
 
-    # tail -f sysvm.log
+   # tail -f sysvm.log
 
 The output to ``sysvm.log`` will look something like this:
 
 .. sourcecode:: bash
 
-    Stopping and starting 1 secondary storage vm(s)...
-    Done stopping and starting secondary storage vm(s)
-    Stopping and starting 1 console proxy vm(s)...
-    Done stopping and starting console proxy vm(s).
-    Stopping and starting 4 running routing vm(s)...
-    Done restarting router(s).
-
-.. Licensed to the Apache Software Foundation (ASF) under one
-   or more contributor license agreements.  See the NOTICE file
-   distributed with this work for additional information#
-   regarding copyright ownership.  The ASF licenses this file
-   to you under the Apache License, Version 2.0 (the
-   "License"); you may not use this file except in compliance
-   with the License.  You may obtain a copy of the License at
-   http://www.apache.org/licenses/LICENSE-2.0
-   Unless required by applicable law or agreed to in writing,
-   software distributed under the License is distributed on an
-   "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-   KIND, either express or implied.  See the License for the
-   specific language governing permissions and limitations
-   under the License.
+   Stopping and starting 1 secondary storage vm(s)...
+   Done stopping and starting secondary storage vm(s)
+   Stopping and starting 1 console proxy vm(s)...
+   Done stopping and starting console proxy vm(s).
+   Stopping and starting 4 running routing vm(s)...
+   Done restarting router(s).
 
 .. sub-section included in upgrade notes.

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/upgrade/_sysvm_templates.rst
----------------------------------------------------------------------
diff --git a/source/upgrade/_sysvm_templates.rst b/source/upgrade/_sysvm_templates.rst
index 28eaef4..68aebcf 100644
--- a/source/upgrade/_sysvm_templates.rst
+++ b/source/upgrade/_sysvm_templates.rst
@@ -18,8 +18,8 @@
 Update System-VM templates
 --------------------------
 
-#. While running the existing |version_to_upgrade| system, log in to the UI as root
-   administrator.
+#. While running the existing |version_to_upgrade| system, log in to the UI as 
+   root administrator.
 
 #. In the left navigation bar, click Templates.
 
@@ -32,86 +32,87 @@ Update System-VM templates
 #. In the Register template dialog box, specify the following values
    (do not change these):
 
-   +-------------------------+-----------------------------------------------------------------------------------------------+
-   | Hypervisor              | Description                                                                                   |
-   +=========================+===============================================================================================+
-   | XenServer               | Name: systemvm-xenserver-|version|                                                            |
-   |                         |                                                                                               |
-   |                         | Description: systemvm-xenserver-|version|                                                     |
-   |                         |                                                                                               |
-   |                         | URL: |sysvm-url-xen|                                                                          |
-   |                         |                                                                                               |
-   |                         | Zone: Choose the zone where this hypervisor is used                                           |
-   |                         |                                                                                               |
-   |                         | Hypervisor: XenServer                                                                         |
-   |                         |                                                                                               |
-   |                         | Format: VHD                                                                                   |
-   |                         |                                                                                               |
-   |                         | OS Type: Debian GNU/Linux 7.0 (64-bit) (or the                                                |
-   |                         | highest Debian release number available in the                                                |
-   |                         | dropdown)                                                                                     |
-   |                         |                                                                                               |
-   |                         | Extractable: no                                                                               |
-   |                         |                                                                                               |
-   |                         | Password Enabled: no                                                                          |
-   |                         |                                                                                               |
-   |                         | Public: no                                                                                    |
-   |                         |                                                                                               |
-   |                         | Featured: no                                                                                  |
-   |                         |                                                                                               |
-   |                         | Routing: yes                                                                                  |
-   +-------------------------+-----------------------------------------------------------------------------------------------+
-   | KVM                     | Name: systemvm-kvm-|version|                                                                  |
-   |                         |                                                                                               |
-   |                         | Description: systemvm-kvm-|version|                                                           |
-   |                         |                                                                                               |
-   |                         | URL: |sysvm-url-kvm|                                                                          |  
-   |                         |                                                                                               |
-   |                         | Zone: Choose the zone where this hypervisor is used                                           |
-   |                         |                                                                                               |
-   |                         | Hypervisor: KVM                                                                               |
-   |                         |                                                                                               |
-   |                         | Format: QCOW2                                                                                 |
-   |                         |                                                                                               |
-   |                         | OS Type: Debian GNU/Linux 7.0 (64-bit) (or the                                                |
-   |                         | highest Debian release number available in the                                                |
-   |                         | dropdown)                                                                                     |
-   |                         |                                                                                               |
-   |                         | Extractable: no                                                                               |
-   |                         |                                                                                               |
-   |                         | Password Enabled: no                                                                          |
-   |                         |                                                                                               |
-   |                         | Public: no                                                                                    |
-   |                         |                                                                                               |
-   |                         | Featured: no                                                                                  |
-   |                         |                                                                                               |
-   |                         | Routing: yes                                                                                  |
-   +-------------------------+-----------------------------------------------------------------------------------------------+
-   | VMware                  | Name: systemvm-vmware-|version|                                                               |
-   |                         |                                                                                               |
-   |                         | Description: systemvm-vmware-|version|                                                        |
-   |                         |                                                                                               |
-   |                         | URL: |sysvm-url-vmware|                                                                       |
-   |                         |                                                                                               |
-   |                         | Zone: Choose the zone where this hypervisor is used                                           |
-   |                         |                                                                                               |
-   |                         | Hypervisor: VMware                                                                            |
-   |                         |                                                                                               |
-   |                         | Format: OVA                                                                                   |
-   |                         |                                                                                               |
-   |                         | OS Type: Debian GNU/Linux 7.0 (64-bit) (or the                                                |
-   |                         | highest Debian release number available in the                                                |
-   |                         | dropdown)                                                                                     |
-   |                         |                                                                                               |
-   |                         | Extractable: no                                                                               |
-   |                         |                                                                                               |
-   |                         | Password Enabled: no                                                                          |
-   |                         |                                                                                               |
-   |                         | Public: no                                                                                    |
-   |                         |                                                                                               |
-   |                         | Featured: no                                                                                  |
-   |                         |                                                                                               |
-   |                         | Routing: yes                                                                                  |
-   +-------------------------+-----------------------------------------------------------------------------------------------+
+   +-------------------------+------------------------------------------------------------+
+   | Hypervisor              | Description                                                |
+   +=========================+============================================================+
+   | XenServer               | Name: systemvm-xenserver-|version|                         |
+   |                         |                                                            |
+   |                         | Description: systemvm-xenserver-|version|                  |
+   |                         |                                                            |
+   |                         | URL: |sysvm-url-xen|                                       |
+   |                         |                                                            |
+   |                         | Zone: Choose the zone where this hypervisor is used        |
+   |                         |                                                            |
+   |                         | Hypervisor: XenServer                                      |
+   |                         |                                                            |
+   |                         | Format: VHD                                                |
+   |                         |                                                            |
+   |                         | OS Type: Debian GNU/Linux 7.0 (64-bit) (or the             |
+   |                         | highest Debian release number available in the             |
+   |                         | dropdown)                                                  |
+   |                         |                                                            |
+   |                         | Extractable: no                                            |
+   |                         |                                                            |
+   |                         | Password Enabled: no                                       |
+   |                         |                                                            |
+   |                         | Public: no                                                 |
+   |                         |                                                            |
+   |                         | Featured: no                                               |
+   |                         |                                                            |
+   |                         | Routing: yes                                               |
+   +-------------------------+------------------------------------------------------------+
+   | KVM                     | Name: systemvm-kvm-|version|                               |
+   |                         |                                                            |
+   |                         | Description: systemvm-kvm-|version|                        |
+   |                         |                                                            |
+   |                         | URL: |sysvm-url-kvm|                                       |  
+   |                         |                                                            |
+   |                         | Zone: Choose the zone where this hypervisor is used        |
+   |                         |                                                            |
+   |                         | Hypervisor: KVM                                            |
+   |                         |                                                            |
+   |                         | Format: QCOW2                                              |
+   |                         |                                                            |
+   |                         | OS Type: Debian GNU/Linux 7.0 (64-bit) (or the             |
+   |                         | highest Debian release number available in the             |
+   |                         | dropdown)                                                  |
+   |                         |                                                            |
+   |                         | Extractable: no                                            |
+   |                         |                                                            |
+   |                         | Password Enabled: no                                       |
+   |                         |                                                            |
+   |                         | Public: no                                                 |
+   |                         |                                                            |
+   |                         | Featured: no                                               |
+   |                         |                                                            |
+   |                         | Routing: yes                                               |
+   +-------------------------+------------------------------------------------------------+
+   | VMware                  | Name: systemvm-vmware-|version|                            |
+   |                         |                                                            |
+   |                         | Description: systemvm-vmware-|version|                     |
+   |                         |                                                            |
+   |                         | URL: |sysvm-url-vmware|                                    |
+   |                         |                                                            |
+   |                         | Zone: Choose the zone where this hypervisor is used        |
+   |                         |                                                            |
+   |                         | Hypervisor: VMware                                         |
+   |                         |                                                            |
+   |                         | Format: OVA                                                |
+   |                         |                                                            |
+   |                         | OS Type: Debian GNU/Linux 7.0 (64-bit) (or the             |
+   |                         | highest Debian release number available in the             |
+   |                         | dropdown)                                                  |
+   |                         |                                                            |
+   |                         | Extractable: no                                            |
+   |                         |                                                            |
+   |                         | Password Enabled: no                                       |
+   |                         |                                                            |
+   |                         | Public: no                                                 |
+   |                         |                                                            |
+   |                         | Featured: no                                               |
+   |                         |                                                            |
+   |                         | Routing: yes                                               |
+   +-------------------------+------------------------------------------------------------+
 
-#. Watch the screen to be sure that the template downloads successfully and enters the **READY** state. Do not proceed until this is successful.
+#. Watch the screen to be sure that the template downloads successfully and 
+   enters the **READY** state. Do not proceed until this is successful.

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/upgrade/_upgrade_header.rst
----------------------------------------------------------------------
diff --git a/source/upgrade/_upgrade_header.rst b/source/upgrade/_upgrade_header.rst
index 22b7261..adcba58 100644
--- a/source/upgrade/_upgrade_header.rst
+++ b/source/upgrade/_upgrade_header.rst
@@ -22,9 +22,9 @@ questions on users@cloudstack.apache.org or dev@cloudstack.apache.org.
    Depreciation of realhostip.com DNS and SSL certificate
    
    The realhostip.com dynamic DNS resolution service is being retired this
-   summer. In advance of that, CloudStack 4.3 and later no longer uses realhostip.com
-   DNS domains or SSL certificates to encrypt Console Proxy or file copy
-   communications.
+   summer. In advance of that, CloudStack 4.3 and later no longer uses 
+   realhostip.com DNS domains or SSL certificates to encrypt Console Proxy or 
+   file copy communications.
 
 Any steps that are hypervisor-specific will be called out with a note.
 
@@ -32,4 +32,6 @@ We recommend reading through this section once or twice before beginning
 your upgrade procedure, and working through it on a test system before
 working on a production system.
 
-.. note:: The following upgrade instructions should be performed regardless of hypervisor type.
+.. note:: 
+   The following upgrade instructions should be performed regardless of 
+   hypervisor type.

http://git-wip-us.apache.org/repos/asf/cloudstack-docs-rn/blob/32bd4fb8/source/upgrade/upgrade-2.2.14.rst
----------------------------------------------------------------------
diff --git a/source/upgrade/upgrade-2.2.14.rst b/source/upgrade/upgrade-2.2.14.rst
index 65a47c8..fca4d03 100644
--- a/source/upgrade/upgrade-2.2.14.rst
+++ b/source/upgrade/upgrade-2.2.14.rst
@@ -13,16 +13,24 @@
    specific language governing permissions and limitations
    under the License.
 
+
 .. |version_to_upgrade| replace:: 2.2.14
 
 Upgrade Instruction from |version_to_upgrade|
 =============================================
 
-This section will guide you from pre-Apache versions of Citrix CloudStack |version_to_upgrade| version to Apache CloudStack |version|.
+This section will guide you from pre-Apache versions of Citrix CloudStack 
+|version_to_upgrade| version to Apache CloudStack |version|.
 
 .. include:: _upgrade_header.rst
 
-.. important:: **Package Structure Changes:** The package structure for CloudStack has changed significantly since the |version_to_upgrade| releases. If you've compiled your own packages, you'll notice that the package names and the number of packages has changed. This is *not* a bug. However, this *does* mean that the procedure is not as simple as an ``apt-get upgrade`` or ``yum update``, so please follow this section carefully.
+.. important:: 
+   **Package Structure Changes:** The package structure for CloudStack has 
+   changed significantly since the |version_to_upgrade| releases. If you've 
+   compiled your own packages, you'll notice that the package names and the 
+   number of packages has changed. This is *not* a bug. However, this *does* 
+   mean that the procedure is not as simple as an ``apt-get upgrade`` or 
+   ``yum update``, so please follow this section carefully.
 
 
 #. Ensure that you query your IPaddress usage records and process them;
@@ -37,9 +45,15 @@ This section will guide you from pre-Apache versions of Citrix CloudStack |versi
    longer be available.
 
 #. If you are using version 2.2.0 - 2.2.13, first upgrade to 2.2.14 by
-   using the instructions in the `2.2.14 Release Notes <http://download.cloud.com/releases/2.2.0/CloudStack2.2.14ReleaseNotes.pdf>`_.
+   using the instructions in the `2.2.14 Release Notes 
+   <http://download.cloud.com/releases/2.2.0/CloudStack2.2.14ReleaseNotes.pdf>`_.
 
-   .. warning:: **KVM Hosts:** If KVM hypervisor is used in your cloud, be sure you completed the step to insert a valid username and password into the host\_details table on each KVM node as described in the 2.2.14 Release Notes. This step is critical, as the database will be encrypted after the upgrade to |version|.
+   .. warning::
+      **KVM Hosts:** If KVM hypervisor is used in your cloud, be sure you 
+      completed the step to insert a valid username and password into the 
+      host\_details table on each KVM node as described in the 2.2.14 Release 
+      Notes. This step is critical, as the database will be encrypted after 
+      the upgrade to |version|.
 
 .. include:: _sysvm_templates.rst
 
@@ -49,8 +63,9 @@ This section will guide you from pre-Apache versions of Citrix CloudStack |versi
    VM template for each hypervisor type. Otherwise, the upgrade will
    fail.
 
+
 Upgrade Steps
--------------------
+-------------
 
 #. (KVM on RHEL 6.0/6.1 only) If your existing CloudStack deployment
    includes one or more clusters of KVM hosts running RHEL 6.0 or RHEL
@@ -70,16 +85,16 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-                      [upgrade]
-                      name=rhel63
-                      baseurl=url-of-your-rhel6.3-repo
-                      enabled=1
-                      gpgcheck=0
-                      [apache CloudStack]
-                      name= Apache CloudStack
-                      baseurl= http://cloudstack.apt-get.eu/rhel/4.4/
-                      enabled=1
-                      gpgcheck=0
+         [upgrade]
+         name=rhel63
+         baseurl=url-of-your-rhel6.3-repo
+         enabled=1
+         gpgcheck=0
+         [apache CloudStack]
+         name= Apache CloudStack
+         baseurl= http://cloudstack.apt-get.eu/rhel/4.4/
+         enabled=1
+         gpgcheck=0
 
       If you are using the community provided package repository, change
       the baseurl to ``http://cloudstack.apt-get.eu/rhel/4.4/``
@@ -92,20 +107,20 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          # yum upgrade
+         # yum upgrade
 
 #. Stop all Usage Servers if running. Run this on all Usage Server
    hosts.
 
    .. sourcecode:: bash
 
-       # service cloud-usage stop
+      # service cloud-usage stop
 
 #. Stop the Management Servers. Run this on all Management Server hosts.
 
    .. sourcecode:: bash
 
-       # service cloud-management stop
+      # service cloud-management stop
 
 #. On the MySQL master, take a backup of the MySQL databases. We
    recommend performing this step even in test upgrades. If there is an
@@ -117,8 +132,8 @@ Upgrade Steps
 
    .. sourcecode:: bash
 
-       # mysqldump -u root -pmysql_password cloud > cloud-backup.dmp
-       # mysqldump -u root -pmysql_password cloud_usage > cloud-usage-backup.dmp
+      # mysqldump -u root -pmysql_password cloud > cloud-backup.dmp
+      # mysqldump -u root -pmysql_password cloud_usage > cloud-usage-backup.dmp
 
 #. Either build RPM/DEB packages as detailed in the Installation Guide,
    or use one of the community provided yum/apt repositories to gain
@@ -127,7 +142,11 @@ Upgrade Steps
 #. If you are using Ubuntu, follow this procedure to upgrade your
    packages. If not, skip to step `13 <#upgrade-rpm-packages-22>`__.
 
-   .. note:: **Community Packages:** This section assumes you're using the community supplied packages for CloudStack. If you've created your own packages and APT repository, substitute your own URL for the ones used in these examples.
+   .. note:: 
+      **Community Packages:** This section assumes you're using the community 
+      supplied packages for CloudStack. If you've created your own packages 
+      and APT repository, substitute your own URL for the ones used in these 
+      examples.
 
    #. The first order of business will be to change the sources list for
       each system with CloudStack packages. This means all management
@@ -141,13 +160,13 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          deb http://cloudstack.apt-get.eu/ubuntu precise 4.0
+         deb http://cloudstack.apt-get.eu/ubuntu precise 4.0
 
       We'll change it to point to the new package repository:
 
       .. sourcecode:: bash
 
-          deb http://cloudstack.apt-get.eu/ubuntu precise 4.4
+         deb http://cloudstack.apt-get.eu/ubuntu precise 4.4
 
       If you're using your own package repository, change this line to
       read as appropriate for your |version| repository.
@@ -156,7 +175,7 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          $ sudo apt-get update
+         $ sudo apt-get update
 
    #. Now that you have the repository configured, it's time to install
       the ``cloudstack-management`` package. This will pull in any other
@@ -164,14 +183,14 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          $ sudo apt-get install cloudstack-management
+         $ sudo apt-get install cloudstack-management
 
    #. On KVM hosts, you will need to manually install the
       ``cloudstack-agent`` package:
 
       .. sourcecode:: bash
 
-          $ sudo apt-get install cloudstack-agent
+         $ sudo apt-get install cloudstack-agent
 
       During the installation of ``cloudstack-agent``, APT will copy
       your ``agent.properties``, ``log4j-cloud.xml``, and
@@ -181,13 +200,12 @@ Upgrade Steps
       When prompted whether you wish to keep your configuration, say
       Yes.
 
-   #. Verify that the file
-      ``/etc/cloudstack/agent/environment.properties`` has a line that
-      reads:
+   #. Verify that the file ``/etc/cloudstack/agent/environment.properties`` 
+      has a line that reads:
 
       .. sourcecode:: bash
 
-          paths.script=/usr/share/cloudstack-common
+         paths.script=/usr/share/cloudstack-common
 
       If not, add the line.
 
@@ -195,9 +213,9 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          service cloud-agent stop
-          killall jsvc
-          service cloudstack-agent start
+         service cloud-agent stop
+         killall jsvc
+         service cloudstack-agent start
 
    #. During the upgrade, ``log4j-cloud.xml`` was simply copied over, so
       the logs will continue to be added to
@@ -207,22 +225,26 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          cd /etc/cloudstack/agent
-          mv log4j-cloud.xml.dpkg-dist log4j-cloud.xml
-          service cloudstack-agent restart
+         cd /etc/cloudstack/agent
+         mv log4j-cloud.xml.dpkg-dist log4j-cloud.xml
+         service cloudstack-agent restart
 
    #. Once the agent is running, you can uninstall the old cloud-\*
       packages from your system:
 
       .. sourcecode:: bash
 
-          sudo dpkg --purge cloud-agent
+         sudo dpkg --purge cloud-agent
 
 #. If you are using CentOS or RHEL, follow this procedure to upgrade
    your packages. If not, skip to step
    `14 <#correct-components-xml-22>`__.
 
-   .. note:: **Community Packages:** This section assumes you're using the community supplied packages for CloudStack. If you've created your own packages and yum repository, substitute your own URL for the ones used in these examples.
+   .. note:: 
+      **Community Packages:** This section assumes you're using the community 
+      supplied packages for CloudStack. If you've created your own packages 
+      and yum repository, substitute your own URL for the ones used in these 
+      examples.
 
    #. The first order of business will be to change the yum repository
       for each system with CloudStack packages. This means all
@@ -237,11 +259,11 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          [apache-cloudstack]
-          name=Apache CloudStack
-          baseurl=http://cloudstack.apt-get.eu/rhel/4.0/
-          enabled=1
-          gpgcheck=0
+         [apache-cloudstack]
+         name=Apache CloudStack
+         baseurl=http://cloudstack.apt-get.eu/rhel/4.0/
+         enabled=1
+         gpgcheck=0
 
       If you are using the community provided package repository, change
       the baseurl to ``http://cloudstack.apt-get.eu/rhel/4.4/``
@@ -255,7 +277,7 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          $ sudo yum upgrade cloud-client
+         $ sudo yum upgrade cloud-client
 
    #. For KVM hosts, you will need to upgrade the ``cloud-agent``
       package, similarly installing the new version as
@@ -263,18 +285,19 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          $ sudo yum upgrade cloud-agent
+         $ sudo yum upgrade cloud-agent
 
       During the installation of ``cloudstack-agent``, the RPM will copy
       your ``agent.properties``, ``log4j-cloud.xml``, and
       ``environment.properties`` from ``/etc/cloud/agent`` to
       ``/etc/cloudstack/agent``.
 
-   #. Verify that the file ``/etc/cloudstack/agent/environment.properties`` has a line that reads:
+   #. Verify that the file ``/etc/cloudstack/agent/environment.properties`` 
+      has a line that reads:
 
       .. sourcecode:: bash
 
-          paths.script=/usr/share/cloudstack-common
+         paths.script=/usr/share/cloudstack-common
 
       If not, add the line.
 
@@ -282,9 +305,9 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          service cloud-agent stop
-          killall jsvc
-          service cloudstack-agent start
+         service cloud-agent stop
+         killall jsvc
+         service cloudstack-agent start
 
 #. If you have made changes to your existing copy of the file
    components.xml in your previous-version CloudStack installation, the
@@ -292,33 +315,37 @@ Upgrade Steps
    following steps to place these changes in a new version of the file
    which is compatible with version 4.0.0-incubating.
 
-   .. note:: How will you know whether you need to do this? If the upgrade output in the previous step included a message like the following, then some custom content was found in your old components.xml, and you need to merge the two files:
+   .. note:: 
+      How will you know whether you need to do this? If the upgrade output in 
+      the previous step included a message like the following, then some 
+      custom content was found in your old components.xml, and you need to 
+      merge the two files:
 
    .. sourcecode:: bash
 
-       warning: /etc/cloud/management/components.xml created as 
-       /etc/cloud/management/components.xml.rpmnew
+      warning: /etc/cloud/management/components.xml created as 
+      /etc/cloud/management/components.xml.rpmnew
 
-   #. Make a backup copy of your
-      ``/etc/cloud/management/components.xml`` file. For example:
+   #. Make a backup copy of your ``/etc/cloud/management/components.xml`` 
+      file. For example:
 
       .. sourcecode:: bash
 
-          # mv /etc/cloud/management/components.xml /etc/cloud/management/components.xml-backup
+         # mv /etc/cloud/management/components.xml /etc/cloud/management/components.xml-backup
 
    #. Copy ``/etc/cloud/management/components.xml.rpmnew`` to create a
       new ``/etc/cloud/management/components.xml``:
 
       .. sourcecode:: bash
 
-          # cp -ap /etc/cloud/management/components.xml.rpmnew /etc/cloud/management/components.xml
+         # cp -ap /etc/cloud/management/components.xml.rpmnew /etc/cloud/management/components.xml
 
    #. Merge your changes from the backup file into the new
       components.xml file.
 
       .. sourcecode:: bash
 
-          # vi /etc/cloudstack/management/components.xml
+         # vi /etc/cloudstack/management/components.xml
 
 #. After upgrading to |version|, API clients are expected to send plain text
    passwords for login and user creation, instead of MD5 hash. If API
@@ -331,17 +358,16 @@ Upgrade Steps
 
    .. sourcecode:: xml
 
-       <!-- Security adapters -->
-       <bean id="userAuthenticators" 
-                       class="com.cloud.utils.component.AdapterList">
-         <property name="Adapters">
-           <list>
-             <ref bean="PlainTextUserAuthenticator"/>
-             <ref bean="MD5UserAuthenticator"/>
-             <ref bean="LDAPUserAuthenticator"/>
-           </list>
-         </property>
-       </bean>
+      <!-- Security adapters -->
+      <bean id="userAuthenticators" class="com.cloud.utils.component.AdapterList">
+        <property name="Adapters">
+          <list>
+            <ref bean="PlainTextUserAuthenticator"/>
+            <ref bean="MD5UserAuthenticator"/>
+            <ref bean="LDAPUserAuthenticator"/>
+          </list>
+        </property>
+      </bean>
 
    PlainTextUserAuthenticator works the same way MD5UserAuthenticator
    worked prior to 4.2.
@@ -353,26 +379,26 @@ Upgrade Steps
    changes in a new version of the file which is compatible with this
    version.
 
-   #. Make a backup copy of your file
-      ``/etc/cloud/management/db.properties``. For example:
+   #. Make a backup copy of your file ``/etc/cloud/management/db.properties``. 
+      For example:
 
       .. sourcecode:: bash
 
-          # mv /etc/cloud/management/db.properties /etc/cloud/management/db.properties-backup
+         # mv /etc/cloud/management/db.properties /etc/cloud/management/db.properties-backup
 
    #. Copy ``/etc/cloud/management/db.properties.rpmnew`` to create a
       new ``/etc/cloud/management/db.properties``:
 
       .. sourcecode:: bash
 
-          # cp -ap /etc/cloud/management/db.properties.rpmnew etc/cloud/management/db.properties
+         # cp -ap /etc/cloud/management/db.properties.rpmnew etc/cloud/management/db.properties
 
    #. Merge your changes from the backup file into the new db.properties
       file.
 
       .. sourcecode:: bash
 
-          # vi /etc/cloudstack/management/db.properties
+         # vi /etc/cloudstack/management/db.properties
 
 #. On the management server node, run the following command. It is
    recommended that you use the command-line flags to provide your own
@@ -381,7 +407,7 @@ Upgrade Steps
 
    .. sourcecode:: bash
 
-       # cloudstack-setup-encryption -e encryption_type -m management_server_key -k database_key
+      # cloudstack-setup-encryption -e encryption_type -m management_server_key -k database_key
 
    When used without arguments, as in the following example, the default
    encryption type and keys will be used:
@@ -409,7 +435,7 @@ Upgrade Steps
 
    .. sourcecode:: bash
 
-       # service cloudstack-management start
+      # service cloudstack-management start
 
    Wait until the databases are upgraded. Ensure that the database
    upgrade is complete. You should see a message like "Complete! Done."
@@ -421,7 +447,7 @@ Upgrade Steps
 
    .. sourcecode:: bash
 
-       # service cloudstack-usage start
+      # service cloudstack-usage start
 
 #. (KVM only) Perform the following additional steps on each KVM host.
 
@@ -436,53 +462,53 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          # service cloud-agent stop
+         # service cloud-agent stop
 
    #. Update the agent software with one of the following command sets
       as appropriate.
 
       .. sourcecode:: bash
 
-          # yum update cloud-*
+         # yum update cloud-*
 
       .. sourcecode:: bash
 
-           # apt-get update
-           # apt-get upgrade cloud-*
+         # apt-get update
+         # apt-get upgrade cloud-*
 
    #. Copy the contents of the ``agent.properties`` file to the new
       ``agent.properties`` file by using the following command
 
       .. sourcecode:: bash
 
-          sed -i 's/com.cloud.agent.resource.computing.LibvirtComputingResource/com.cloud.hypervisor.kvm.resource.LibvirtComputingResource/g' /etc/cloudstack/agent/agent.properties
+         sed -i 's/com.cloud.agent.resource.computing.LibvirtComputingResource/com.cloud.hypervisor.kvm.resource.LibvirtComputingResource/g' /etc/cloudstack/agent/agent.properties
 
    #. Upgrade all the existing bridge names to new bridge names by
       running this script:
 
       .. sourcecode:: bash
 
-           # cloudstack-agent-upgrade
+         # cloudstack-agent-upgrade
 
    #. Install a libvirt hook with the following commands:
 
       .. sourcecode:: bash
 
-           # mkdir /etc/libvirt/hooks
-           # cp /usr/share/cloudstack-agent/lib/libvirtqemuhook /etc/libvirt/hooks/qemu
-           # chmod +x /etc/libvirt/hooks/qemu
+         # mkdir /etc/libvirt/hooks
+         # cp /usr/share/cloudstack-agent/lib/libvirtqemuhook /etc/libvirt/hooks/qemu
+         # chmod +x /etc/libvirt/hooks/qemu
 
    #. Restart libvirtd.
 
       .. sourcecode:: bash
 
-          # service libvirtd restart
+         # service libvirtd restart
 
    #. Start the agent.
 
       .. sourcecode:: bash
 
-          # service cloudstack-agent start
+         # service cloudstack-agent start
 
    #. When the Management Server is up and running, log in to the
       CloudStack UI and restart the virtual router for proper
@@ -506,8 +532,8 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          # nohup cloudstack-sysvmadm -d 192.168.1.5 -u cloud -p password -c -r > sysvm.log 2>&1 &
-          # tail -f sysvm.log
+         # nohup cloudstack-sysvmadm -d 192.168.1.5 -u cloud -p password -c -r > sysvm.log 2>&1 &
+         # tail -f sysvm.log
 
       This might take up to an hour or more to run, depending on the
       number of accounts in the system.
@@ -517,7 +543,7 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          # tail -f sysvm.log
+         # tail -f sysvm.log
 
       The content should be like the following:
 
@@ -574,7 +600,7 @@ Upgrade Steps
 
    .. sourcecode:: bash
 
-       Cloudstack Release 4.0.0-incubating Mon Oct 9 15:10:04 PST 2012
+      Cloudstack Release 4.0.0-incubating Mon Oct 9 15:10:04 PST 2012
 
 #. If needed, upgrade all Citrix XenServer hypervisor hosts in your
    cloud to a version supported by CloudStack 4.0.0-incubating. The
@@ -604,14 +630,14 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          /opt/xensource/bin/cloud-clean-vlan.sh
+         /opt/xensource/bin/cloud-clean-vlan.sh
 
    #. Prepare the upgrade by running the following on one XenServer
       host:
 
       .. sourcecode:: bash
 
-          /opt/xensource/bin/cloud-prepare-upgrade.sh
+         /opt/xensource/bin/cloud-prepare-upgrade.sh
 
       If you see a message like "can't eject CD", log in to the VM and
       umount the CD, then run this script again.
@@ -625,28 +651,35 @@ Upgrade Steps
 
       .. sourcecode:: bash
 
-          xe patch-upload file-name=XS602E003.xsupdate
+         xe patch-upload file-name=XS602E003.xsupdate
 
       Make a note of the output from this command, which is a UUID for
       the hotfix file. You'll need it in another step later.
 
-      .. note:: (Optional) If you are applying other hotfixes as well, you can repeat the commands in this section with the appropriate hotfix number. For example, XS602E004.xsupdate.
+      .. note:: 
+         (Optional) If you are applying other hotfixes as well, you can repeat 
+         the commands in this section with the appropriate hotfix number. For 
+         example, XS602E004.xsupdate.
 
    #. Manually live migrate all VMs on this host to another host. First,
       get a list of the VMs on this host:
 
       .. sourcecode:: bash
 
-          # xe vm-list
+         # xe vm-list
 
       Then use this command to migrate each VM. Replace the example host
       name and VM name with your own:
 
       .. sourcecode:: bash
 
-          # xe vm-migrate live=true host=host-name vm=VM-name
+         # xe vm-migrate live=true host=host-name vm=VM-name
 
-      .. note:: **Troubleshooting:** If you see a message like "You attempted an operation on a VM which requires PV drivers to be installed but the drivers were not detected," run: ``/opt/xensource/bin/make_migratable.sh b6cf79c8-02ee-050b-922f-49583d9f1a14``.
+      .. note:: 
+         **Troubleshooting:** If you see a message like "You attempted an 
+         operation on a VM which requires PV drivers to be installed but the 
+         drivers were not detected," run: 
+         ``/opt/xensource/bin/make_migratable.sh b6cf79c8-02ee-050b-922f-49583d9f1a14``.
 
    #. Apply the hotfix. First, get the UUID of this host:
 
@@ -663,24 +696,24 @@ Upgrade Steps
    #. Copy the following files from the CloudStack Management Server to
       the host.
 
-       +-------------------------+-------------------------------------------------+
-       | Copy from here...       | ...to here                                      |
-       +=========================+=================================================+
-       | ``/usr/share/cloudstack | ``/opt/xensource/sm/NFSSR.py``                  |
-       | -common/scripts/vm/hype |                                                 |
-       | rvisor/xenserver/xenser |                                                 |
-       | ver60/NFSSR.py``        |                                                 |
-       +-------------------------+-------------------------------------------------+
-       | ``/usr/share/cloudstack | ``/opt/xensource/bin/setupxenserver.sh``        |
-       | -common/scripts/vm/hype |                                                 |
-       | rvisor/xenserver/setupx |                                                 |
-       | enserver.sh``           |                                                 |
-       +-------------------------+-------------------------------------------------+
-       | ``/usr/lib64/cloudstack | ``/opt/xensource/bin/make_migratable.sh``       |
-       | -common/scripts/vm/hype |                                                 |
-       | rvisor/xenserver/make_m |                                                 |
-       | igratable.sh``          |                                                 |
-       +-------------------------+-------------------------------------------------+
+      +-------------------------+-------------------------------------------------+
+      | Copy from here...       | ...to here                                      |
+      +=========================+=================================================+
+      | ``/usr/share/cloudstack | ``/opt/xensource/sm/NFSSR.py``                  |
+      | -common/scripts/vm/hype |                                                 |
+      | rvisor/xenserver/xenser |                                                 |
+      | ver60/NFSSR.py``        |                                                 |
+      +-------------------------+-------------------------------------------------+
+      | ``/usr/share/cloudstack | ``/opt/xensource/bin/setupxenserver.sh``        |
+      | -common/scripts/vm/hype |                                                 |
+      | rvisor/xenserver/setupx |                                                 |
+      | enserver.sh``           |                                                 |
+      +-------------------------+-------------------------------------------------+
+      | ``/usr/lib64/cloudstack | ``/opt/xensource/bin/make_migratable.sh``       |
+      | -common/scripts/vm/hype |                                                 |
+      | rvisor/xenserver/make_m |                                                 |
+      | igratable.sh``          |                                                 |
+      +-------------------------+-------------------------------------------------+
 
    #. (Only for hotfixes XS602E005 and XS602E007) You need to apply a
       new Cloud Support Pack.
@@ -713,15 +746,17 @@ Upgrade Steps
 
       ``/opt/xensource/bin/setupxenserver.sh``
 
-      .. note:: If the message "mv: cannot stat \`/etc/cron.daily/logrotate': No such file or directory" appears, you can safely ignore it.
+      .. note:: 
+         If the message "mv: cannot stat \`/etc/cron.daily/logrotate': No such 
+         file or directory" appears, you can safely ignore it.
 
    #. Run the following:
 
       .. sourcecode:: bash
 
-        ``for pbd in `xe pbd-list currently-attached=false| grep ^uuid | awk '{print $NF}'`; do xe pbd-plug uuid=$pbd ; ``
+         ``for pbd in `xe pbd-list currently-attached=false| grep ^uuid | awk '{print $NF}'`; do xe pbd-plug uuid=$pbd ; ``
 
    #. On each slave host in the Xen pool, repeat these steps, starting
       from "manually live migrate VMs."
 
-.. include:: /global.rst
\ No newline at end of file
+.. include:: /global.rst


Mime
View raw message