cloudstack-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wid...@apache.org
Subject git commit: kvm: It's no longer required to have VNC listen in 0.0.0.0
Date Mon, 03 Feb 2014 11:42:48 GMT
Updated Branches:
  refs/heads/master 4ae5cb519 -> 4f17c0bf0


kvm: It's no longer required to have VNC listen in 0.0.0.0

In both the master and 4.3 branch there is a patch which sets
the VNC address to the private IP of the hypervisor and during
migration this will be changed to the private IP of the destination
hypervisor.

Binding VNC on 0.0.0.0 is a potential security issue with the hypervisors
also have a public IP address and the VNC ports are not firewalled.


Project: http://git-wip-us.apache.org/repos/asf/cloudstack-docs/repo
Commit: http://git-wip-us.apache.org/repos/asf/cloudstack-docs/commit/4f17c0bf
Tree: http://git-wip-us.apache.org/repos/asf/cloudstack-docs/tree/4f17c0bf
Diff: http://git-wip-us.apache.org/repos/asf/cloudstack-docs/diff/4f17c0bf

Branch: refs/heads/master
Commit: 4f17c0bf02bfe292972bf631387c1e37c5e9995d
Parents: 4ae5cb5
Author: Wido den Hollander <wido@widodh.nl>
Authored: Mon Feb 3 12:37:17 2014 +0100
Committer: Wido den Hollander <wido@widodh.nl>
Committed: Mon Feb 3 12:37:17 2014 +0100

----------------------------------------------------------------------
 en-US/hypervisor-host-install-libvirt.xml | 5 -----
 1 file changed, 5 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cloudstack-docs/blob/4f17c0bf/en-US/hypervisor-host-install-libvirt.xml
----------------------------------------------------------------------
diff --git a/en-US/hypervisor-host-install-libvirt.xml b/en-US/hypervisor-host-install-libvirt.xml
index c4be67e..d3d6b9b 100644
--- a/en-US/hypervisor-host-install-libvirt.xml
+++ b/en-US/hypervisor-host-install-libvirt.xml
@@ -47,11 +47,6 @@
             <programlisting>libvirtd_opts="-d -l"</programlisting>
         </listitem>
         <listitem>
-            <para>In order to have the VNC Console work we have to make sure it will
bind on 0.0.0.0. We do this by editing <filename>/etc/libvirt/qemu.conf</filename></para>
-            <para>Make sure this parameter is set:</para>
-            <programlisting>vnc_listen = "0.0.0.0"</programlisting>
-        </listitem>
-        <listitem>
             <para>Restart libvirt</para>
             <para>In RHEL or CentOS:</para>
             <programlisting><command>$ service libvirtd restart</command></programlisting>


Mime
View raw message