cloudstack-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From h...@apache.org
Subject [2/2] git commit: updated refs/heads/master to f74e635
Date Tue, 25 Jun 2013 19:22:26 GMT
Setting the required version of libvirt to 10.0 for the openvswitch
support. This version actually supports setting the vlan tag on an
interface.


Project: http://git-wip-us.apache.org/repos/asf/cloudstack/repo
Commit: http://git-wip-us.apache.org/repos/asf/cloudstack/commit/f74e6352
Tree: http://git-wip-us.apache.org/repos/asf/cloudstack/tree/f74e6352
Diff: http://git-wip-us.apache.org/repos/asf/cloudstack/diff/f74e6352

Branch: refs/heads/master
Commit: f74e635225c1241054985c8911be59233b747f60
Parents: 881a6e1
Author: Hugo Trippaers <htrippaers@schubergphilis.com>
Authored: Thu Jun 20 08:11:05 2013 -0700
Committer: Hugo Trippaers <htrippaers@schubergphilis.com>
Committed: Tue Jun 25 12:21:25 2013 -0700

----------------------------------------------------------------------
 .../cloud/hypervisor/kvm/resource/LibvirtComputingResource.java  | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cloudstack/blob/f74e6352/plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java
----------------------------------------------------------------------
diff --git a/plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java
b/plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java
index 60cde8c..b1bc99d 100755
--- a/plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java
+++ b/plugins/hypervisors/kvm/src/com/cloud/hypervisor/kvm/resource/LibvirtComputingResource.java
@@ -722,8 +722,8 @@ ServerResource {
             conn = LibvirtConnection.getConnection();
 
             if (_bridgeType == BridgeType.OPENVSWITCH) {
-                if (conn.getLibVirVersion() < (9 * 1000 + 11)) {
-                    throw new ConfigurationException("LibVirt version 0.9.11 required for
openvswitch support, but version "
+                if (conn.getLibVirVersion() < (10 * 1000 + 0)) {
+                    throw new ConfigurationException("LibVirt version 0.10.0 required for
openvswitch support, but version "
                             + conn.getLibVirVersion() + " detected");
                 }
             }


Mime
View raw message