cloudstack-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bfede...@apache.org
Subject [21/25] git commit: updated refs/heads/ui-vpc-redesign to 7ac0141
Date Wed, 22 May 2013 18:46:05 GMT
CLOUDSTACK-2516: Adding upgrade steps to deal with authenticator changes


Project: http://git-wip-us.apache.org/repos/asf/cloudstack/repo
Commit: http://git-wip-us.apache.org/repos/asf/cloudstack/commit/e720e8a1
Tree: http://git-wip-us.apache.org/repos/asf/cloudstack/tree/e720e8a1
Diff: http://git-wip-us.apache.org/repos/asf/cloudstack/diff/e720e8a1

Branch: refs/heads/ui-vpc-redesign
Commit: e720e8a1a62722c2c032aafe00848079fbd92a03
Parents: 5b80af0
Author: Chip Childers <chipchilders@apache.org>
Authored: Wed May 22 12:14:47 2013 -0400
Committer: Chip Childers <chipchilders@apache.org>
Committed: Wed May 22 12:16:13 2013 -0400

----------------------------------------------------------------------
 docs/en-US/Release_Notes.xml |   53 ++++++++++++++++++++++++++++++++++++-
 1 files changed, 52 insertions(+), 1 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cloudstack/blob/e720e8a1/docs/en-US/Release_Notes.xml
----------------------------------------------------------------------
diff --git a/docs/en-US/Release_Notes.xml b/docs/en-US/Release_Notes.xml
index dca95d3..25e1175 100644
--- a/docs/en-US/Release_Notes.xml
+++ b/docs/en-US/Release_Notes.xml
@@ -4586,7 +4586,7 @@ under the License.
       versions of Citrix CloudStack (last version prior to Apache is 3.0.2) and from the
releases
       made while CloudStack was in the Apache Incubator.</para>
     <para>If you run into any issues during upgrades, please feel free to ask questions
on
-      users@apache.cloudstack.org or dev@apache.cloudstack.org.</para>
+      users@cloudstack.apache.org or dev@cloudstack.apache.org.</para>
     <section id="upgrade-from-4.0-to-4.1">
       <title>Upgrade from 4.0.x to 4.1.0</title>
       <para>This section will guide you from &PRODUCT; 4.0.x versions to &PRODUCT;
4.1.0.</para>
@@ -4647,6 +4647,23 @@ under the License.
             automatically. (If you're unsure, we recommend making a backup of the original
               <filename>components.xml</filename> to be on the safe side.</para>
         </listitem>
+        <listitem>
+            <para>After upgrading to 4.1, API clients are expected to send plain text
passwords for login and user creation, instead of MD5 hash. Incase, api client changes are
not acceptable, following changes are to be made for backward compatibility:</para>
+            <para>Modify componentsContext.xml, and make PlainTextUserAuthenticator
as the default authenticator (1st entry in the userAuthenticators adapter list is default)</para>
+            <programlisting language="XML">
+&lt;!-- Security adapters --&gt;
+&lt;bean id="userAuthenticators" class="com.cloud.utils.component.AdapterList"&gt;
+  &lt;property name="Adapters"&gt;
+    &lt;list&gt;
+      &lt;ref bean="PlainTextUserAuthenticator"/&gt;
+      &lt;ref bean="MD5UserAuthenticator"/&gt;
+      &lt;ref bean="LDAPUserAuthenticator"/&gt;
+    &lt;/list&gt;
+  &lt;/property&gt;
+&lt;/bean&gt;
+            </programlisting>
+            <para>PlainTextUserAuthenticator works the same way MD5UserAuthenticator
worked prior to 4.1.</para>
+        </listitem>
         <listitem id="upgrade-deb-packages">
           <para>If you are using Ubuntu, follow this procedure to upgrade your packages.
If not,
             skip to step <xref linkend="upgrade-rpm-packages"/>.</para>
@@ -5111,6 +5128,23 @@ service cloudstack-agent start
           </note>
         </listitem>
         <listitem>
+            <para>After upgrading to 4.1, API clients are expected to send plain text
passwords for login and user creation, instead of MD5 hash. Incase, api client changes are
not acceptable, following changes are to be made for backward compatibility:</para>
+            <para>Modify componentsContext.xml, and make PlainTextUserAuthenticator
as the default authenticator (1st entry in the userAuthenticators adapter list is default)</para>
+            <programlisting language="XML">
+&lt;!-- Security adapters --&gt;
+&lt;bean id="userAuthenticators" class="com.cloud.utils.component.AdapterList"&gt;
+  &lt;property name="Adapters"&gt;
+    &lt;list&gt;
+      &lt;ref bean="PlainTextUserAuthenticator"/&gt;
+      &lt;ref bean="MD5UserAuthenticator"/&gt;
+      &lt;ref bean="LDAPUserAuthenticator"/&gt;
+    &lt;/list&gt;
+  &lt;/property&gt;
+&lt;/bean&gt;
+            </programlisting>
+            <para>PlainTextUserAuthenticator works the same way MD5UserAuthenticator
worked prior to 4.1.</para>
+        </listitem>
+        <listitem>
           <para>Start the first Management Server. Do not start any other Management
Server nodes
             yet.</para>
           <programlisting language="Bash"><prompt>#</prompt> service cloudstack-management
start</programlisting>
@@ -5689,6 +5723,23 @@ service cloudstack-agent start
           </orderedlist>
         </listitem>
         <listitem>
+            <para>After upgrading to 4.1, API clients are expected to send plain text
passwords for login and user creation, instead of MD5 hash. Incase, api client changes are
not acceptable, following changes are to be made for backward compatibility:</para>
+            <para>Modify componentsContext.xml, and make PlainTextUserAuthenticator
as the default authenticator (1st entry in the userAuthenticators adapter list is default)</para>
+            <programlisting language="XML">
+&lt;!-- Security adapters --&gt;
+&lt;bean id="userAuthenticators" class="com.cloud.utils.component.AdapterList"&gt;
+  &lt;property name="Adapters"&gt;
+    &lt;list&gt;
+      &lt;ref bean="PlainTextUserAuthenticator"/&gt;
+      &lt;ref bean="MD5UserAuthenticator"/&gt;
+      &lt;ref bean="LDAPUserAuthenticator"/&gt;
+    &lt;/list&gt;
+  &lt;/property&gt;
+&lt;/bean&gt;
+            </programlisting>
+            <para>PlainTextUserAuthenticator works the same way MD5UserAuthenticator
worked prior to 4.1.</para>
+        </listitem>
+        <listitem>
           <para>If you have made changes to your existing copy of the
               <filename>/etc/cloud/management/db.properties</filename> file in
your previous-version
             CloudStack installation, the changes will be preserved in the upgrade. However,
you need


Mime
View raw message