cloudstack-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From t..@apache.org
Subject git commit: Marvin doesn't require python 2.7, the tests do
Date Sat, 08 Dec 2012 01:19:06 GMT
Updated Branches:
  refs/heads/master 1ed2f4bf0 -> a7d7f85e4


Marvin doesn't require python 2.7, the tests do

To compile marvin using maven any standard python interpreter above 2.4
is sufficient. The tests under test/integration will need 2.7 to run.

Signed-off-by: Prasanna Santhanam <tsp@apache.org> 1354929362 -0800


Project: http://git-wip-us.apache.org/repos/asf/incubator-cloudstack/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-cloudstack/commit/a7d7f85e
Tree: http://git-wip-us.apache.org/repos/asf/incubator-cloudstack/tree/a7d7f85e
Diff: http://git-wip-us.apache.org/repos/asf/incubator-cloudstack/diff/a7d7f85e

Branch: refs/heads/master
Commit: a7d7f85e40ca4ba58c02d4f8bf17f1f74bc6e54a
Parents: 1ed2f4b
Author: Prasanna Santhanam <tsp@apache.org>
Authored: Fri Dec 7 17:16:02 2012 -0800
Committer: Prasanna Santhanam <tsp@apache.org>
Committed: Fri Dec 7 17:17:02 2012 -0800

----------------------------------------------------------------------
 tools/marvin/setup.py |    4 ----
 1 files changed, 0 insertions(+), 4 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-cloudstack/blob/a7d7f85e/tools/marvin/setup.py
----------------------------------------------------------------------
diff --git a/tools/marvin/setup.py b/tools/marvin/setup.py
index f0de384..fea53d0 100644
--- a/tools/marvin/setup.py
+++ b/tools/marvin/setup.py
@@ -20,10 +20,6 @@ from setuptools import setup
 from sys import version
 import sys
 
-if version < "2.7":
-    print "Marvin needs at least python 2.7, found : \n%s"%version
-    sys.exit(1)
-
 setup(name="Marvin",
       version="0.1.0",
       description="Marvin - Python client for testing cloudstack",


Mime
View raw message