climate-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jarifibrahim <...@git.apache.org>
Subject [GitHub] climate issue #418: CLIMATE-886 Updating front-end dependencies.
Date Thu, 10 Nov 2016 18:34:06 GMT
Github user jarifibrahim commented on the issue:

    https://github.com/apache/climate/pull/418
  
    @Omkar20895 `npm install` would create a folder `node_modules` and install all the dependencies
in it. If you do `npm install -g` then the dependencies are installed globally.
    
    I tried your PR and got the following errors
    ```
    npm WARN deprecated graceful-fs@2.0.3: graceful-fs v3.0.0 and before will fail on node
releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls
graceful-fs' to find it in the tree.
    npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid
a RegExp DoS issue
    npm WARN deprecated CSSselect@0.4.1: the module is now available as 'css-select'
    npm WARN deprecated CSSwhat@0.4.7: the module is now available as 'css-what'
    npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid
a RegExp DoS issue
    npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid
a RegExp DoS issue
    npm WARN deprecated tough-cookie@0.9.15: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
    npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid
a RegExp DoS issue
    npm WARN deprecated tough-cookie@0.12.1: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
    npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is
now out of date with respect to npm
    npm WARN prefer global coffee-script@1.10.0 should be installed with -g
    npm WARN prefer global jshint@2.9.4 should be installed with -g
    
    
    +-- UNMET PEER DEPENDENCY jasmine-core@*
    
    
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.15:
wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
    npm WARN karma-jasmine@1.0.2 requires a peer of jasmine-core@* but none was installed.
    ```
    
    Btw, [npm-check-update](https://www.npmjs.com/package/npm-check-updates)  package might
be useful in future.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message