click-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mykhaylo Kotsur <micc...@gmail.com>
Subject Re: Default Autobinding|autobinding="true" not working on Click 2.1.0
Date Sun, 14 Mar 2010 16:39:43 GMT
Hi,

But section 1.2 contains example where protected variables are auto-binded
as well.
http://click.apache.org/docs/user-guide/htmlsingle/click-book.html#control-listener-type-1

Seems like a mistake in manual.

Mykhailo



On Fri, Mar 5, 2010 at 12:09 AM, Gilberto C. Andrade
<gilbertoca@gmail.com>wrote:

> I found the problem! My mistake!
> I used protected on my attributes instead of public. Click user guide on
> 4.2.3.3 section says you can use only public fields.
> So, sorry to bothering you.
>
> Thanks for you attention,
>
> Gilberto
>
>
>
> On Wed, Mar 3, 2010 at 10:50 AM, Gilberto C. Andrade <gilbertoca@gmail.com
> > wrote:
>
>> Hi, Bob! Sorry for delay!
>>
>> Please, can you try the attached project? It is a maven click project,
>> just unzip it and open it with netbeans (I'm using the 6.8 version) and
>> Ctrl+F6 on ActionDemoTest.java file.
>> Or on cmd, mvn jetty:run to see the problem.
>>
>>
>> On Thu, Feb 25, 2010 at 6:25 PM, Bob Schellink <sabob1@gmail.com> wrote:
>>
>>> Hi Gilberto,
>>>
>>> Just tested against click-examples and it works for me. Can you double
>>> check your
>>
>>
>> I think several examples in click-examples are setup to use bindable
>> interface. So, you can't the problem.
>>
>> Thanks,
>>
>> Gilberto
>>
>>
>> click.xml file is updated in your war file? Perhaps do a clean redeploy?
>>>
>>> regards
>>>
>>> bob
>>>
>>>
>>>
>>> On 26/02/2010 01:57 AM, Gilberto C. Andrade wrote:
>>>
>>>> Hi,
>>>>
>>>> My click.xml file:
>>>> <?xml version="1.0" encoding="UTF-8"?>
>>>> <click-app>
>>>> <pages package="park.web.page" autobinding="true"/>
>>>> <mode value="debug"/>
>>>> </click-app>
>>>>
>>>> It doesn't matter if click.xml has or not autobinding="true".
>>>> It does work with autobinding="annotation". But I'm using it.
>>>>
>>>> Any idea how to setup it correctly?
>>>>
>>>> Thanks,
>>>>
>>>> Gilberto
>>>>
>>>>
>>>
>>
>

Mime
View raw message