click-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian A." <>
Subject Re: Rename Partial
Date Sun, 18 Jul 2010 08:07:33 GMT
>>> Fragment, (Snippet, Slice, Brick, Pagelet, Partlet, Slicelet) ?
> How about Payload? It is abstract enough and easy to document for both Ajax and non Ajax
Payload describes precisely, but: for most no-native English speakers, 
the first that comes into their mind hearing "Payload" is something 
related to "payment" :).

The response might be described as "Content", but that's waaay too 
general :(.

> I'm trying hard not to use the word "Response" which is already taken by HttpServletResponse.
The Servlet API is using only "HttpServletResponse" not simply "Response".

SimpleWeb (the high performance async Java web server)
seems to use "Response" too, so maybe it's not that bad.


View raw message