click-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian A." <>
Subject Re: Rename Partial
Date Sun, 18 Jul 2010 07:50:36 GMT
>> Fragment, (Snippet, Slice, Brick, Pagelet, Partlet, Slicelet) ?
>> The "binary" content returned, it's indeed "complete", not "partial",
>> but maybe the problem (and user confusion) is not with the naming, but
>> the fact that "Partial" renders non-Ajax binary content too? For those
>> binary resources, a much better name could be e.g. "Resource", so
>> E.g. Something like
>> public class Partial extends/implements Resource {
>>   ...
>> }
>> thus for "complete" binary responses to return a Resource, not a Partial?
>> Could this be an approach?
> Not sure that Resource is the proper name though. It might be binary
> content that is generated on the fly.
"Resource would be the "Browser"/"User" view on that generated content - 
being static or dynamic. The same way a HTML Page is the same from the 
Browser/User perspective even if it's dynamically created or not.

The same wording seem to be used by REST and RESTful web services (what 
comes back is a "resource")

> Both JSF and Wicket have settled on Behaviors so I think we should leverage it as well.
That was the first issue mentioned to me by some users: it's just too 
Wicket like :).

> Callbacks
> might be more familiar to programmers but not as a means to handle Ajax requests. Callbacks
> normally used for inter object invocations not handling browser requests.
Something familiar to most Windows users (but present in many 
programming languages) might be "Handle" or "AjaxHandle".


View raw message