click-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian A." <>
Subject Re: Rename Partial
Date Sat, 17 Jul 2010 11:11:33 GMT
> I've been thinking about renaming the Partial object to something more generic. I settled
on Partial
> initially for handling Ajax requests only. However there are use cases where a Page Action
> handle non-Ajax requests, for example binary content (PNG, PDF, Excel) etc.
> Any suggestions?
Fragment, (Snippet, Slice, Brick, Pagelet, Partlet, Slicelet) ?

The "binary" content returned, it's indeed "complete", not "partial", 
but maybe the problem (and user confusion) is not with the naming, but 
the fact that "Partial" renders non-Ajax binary content too? For those 
binary resources, a much better name could be e.g. "Resource", so

E.g. Something like
public class Partial extends/implements Resource {
thus for "complete" binary responses to return a Resource, not a Partial?

Could this be an approach?

P.S. IMHO the naming "Behavior" is more confusing than "Callback", since 
the "Callback" concept is quite known to most programmers.

View raw message