click-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Schellink <sab...@gmail.com>
Subject Re: Rename Partial
Date Sat, 17 Jul 2010 11:34:24 GMT
On 17/07/2010 21:11, Adrian A. wrote:
> Fragment, (Snippet, Slice, Brick, Pagelet, Partlet, Slicelet) ?
> 
> The "binary" content returned, it's indeed "complete", not "partial",
> but maybe the problem (and user confusion) is not with the naming, but
> the fact that "Partial" renders non-Ajax binary content too? For those
> binary resources, a much better name could be e.g. "Resource", so
> 
> E.g. Something like
> public class Partial extends/implements Resource {
>  ...
> }
> thus for "complete" binary responses to return a Resource, not a Partial?
> 
> Could this be an approach?


This is my thinking as well. Not sure that Resource is the proper name though. It might be
binary
content that is generated on the fly. So it's more a case of encapsulating a response. I'm
hoping we
can find a single concept for both use cases: Behaviors and Page Actions.


> Adrian.
> P.S. IMHO the naming "Behavior" is more confusing than "Callback", since
> the "Callback" concept is quite known to most programmers.


Both JSF and Wicket have settled on Behaviors so I think we should leverage it as well. Callbacks
might be more familiar to programmers but not as a means to handle Ajax requests. Callbacks
are
normally used for inter object invocations not handling browser requests.

Bob

Mime
View raw message