click-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ke Sun (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CLK-628) Does not work under the latest Google App Engine 1.3.1
Date Thu, 18 Feb 2010 13:07:27 GMT

    [ https://issues.apache.org/jira/browse/CLK-628?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12835182#action_12835182
] 

Ke Sun commented on CLK-628:
----------------------------

Hi Bob,

Thanks for your response.  I tried to replace the Click Jars with 2.1.0. It
causes other incompatible problems with Click JPA implementation. I did not
dive into the problem yet, but will try.

By the way, I am confused by the JavaDoc of Class GoogleAppEngineListener:

 <?xml version="1.0" encoding="utf-8"?>
 <web-app xmlns="http://java.sun.com/xml/ns/javaee" version="2.5">

     <listener>
         <listener-class>org.apache.click.extras.gae.GoogleAppEngineListener</listener-class>
     </listener>

     <servlet>
         <servlet-name>ClickClickServlet</servlet-name>
         <servlet-class>net.sf.clickclick.ClickClickServlet</servlet-class>
         <load-on-startup>0</load-on-startup>
     </servlet>
     <servlet-mapping>
         <servlet-name>ClickClickServlet</servlet-name>
         <url-pattern>*.htm</url-pattern>
     </servlet-mapping>
 </web-app>

where is the class "net.sf.clickclick.ClickClickServlet"? Is it should be
"org.apache.click.ClickServlet" instead?


Best Wishes,

Ke



2010/2/17 Bob Schellink (JIRA) <jira@apache.org>



> Does not work under the latest Google App Engine 1.3.1
> ------------------------------------------------------
>
>                 Key: CLK-628
>                 URL: https://issues.apache.org/jira/browse/CLK-628
>             Project: Click
>          Issue Type: Bug
>          Components: extras
>    Affects Versions: 2.1.0, 2.1.0 RC1
>         Environment: OS: Ubuntu 9.10
> Click: 2.1.0
> GAE: 1.3.1 (Eclipse GAE plugin)
> IDE: Eclipse  
>            Reporter: Ke Sun
>
> Click 2.1.0 does not work under the latest GAE (1.3.1). I tried the demo http://code.google.com/p/click-jpa-demo/.
It do works if I switch to GAE 1.2.2. Under GAE 1.3.1, GAE pops up the  not-found  page.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message