click-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrey Rybin (JIRA)" <j...@apache.org>
Subject [jira] Created: (CLK-632) MinimumYear & MaximumYear: 1) aren't used in CalendarField (JS Popup Calendar allows You select any year) 2) aren't used for validation in DateField&CalendarField
Date Wed, 24 Feb 2010 09:50:28 GMT
MinimumYear & MaximumYear: 1) aren't used in CalendarField (JS Popup Calendar allows You
select any year) 2) aren't used for validation in DateField&CalendarField
------------------------------------------------------------------------------------------------------------------------------------------------------------------

                 Key: CLK-632
                 URL: https://issues.apache.org/jira/browse/CLK-632
             Project: Click
          Issue Type: Bug
          Components: click-calendar, core
    Affects Versions: 2.1.0
            Reporter: Andrey Rybin


1) DateField popup calendar allows you enter only year from range MinimumYear, but same feature
in CalendarField is broken.
CalendarField aren't used MinimumYear & MaximumYear at all.


2) it  looks intuitive for user that MinimumYear & MaximumYear are used in validation,
and he can't receive date less than MinimumYear-01-01 and great than MaximumYear-12-31.
But both fields aren't used for value validation at all ;-(


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message