click-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Schellink (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CLK-594) click-nodeps has incorrect dependencies in pom
Date Thu, 12 Nov 2009 08:39:39 GMT

     [ https://issues.apache.org/jira/browse/CLK-594?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bob Schellink resolved CLK-594.
-------------------------------

    Resolution: Duplicate

Thanks Victor, this has been fixed as CLK-593.

> click-nodeps has incorrect dependencies in pom
> ----------------------------------------------
>
>                 Key: CLK-594
>                 URL: https://issues.apache.org/jira/browse/CLK-594
>             Project: Click
>          Issue Type: Bug
>          Components: extras
>    Affects Versions: 2.1.0 RC1
>         Environment: Apache Maven 2.2.1 (rdebian-1)
> Java version: 1.6.0_15
> Java home: /usr/lib/jvm/java-6-sun-1.6.0.15/jre
> Default locale: en_AU, platform encoding: UTF-8
> OS name: "linux" version: "2.6.31-14-generic-pae" arch: "i386" Family: "unix"
>            Reporter: Victor Leung
>            Priority: Minor
>   Original Estimate: 0.08h
>  Remaining Estimate: 0.08h
>
> When click-extras is added to the project pom, Maven reports the following error:
> Downloading: http://repo1.maven.org/maven2/velocity/velocity/1.6.2/velocity-1.6.2.pom
> [INFO] Unable to find resource 'velocity:velocity:pom:1.6.2' in repository central (http://repo1.maven.org/maven2)
> Downloading: http://repo1.maven.org/maven2/velocity/velocity/1.6.2/velocity-1.6.2.jar
> [INFO] Unable to find resource 'velocity:velocity:jar:1.6.2' in repository central (http://repo1.maven.org/maven2)
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> In click-nodeps-2.1.0-RC1-incubating.pom, the velocity dependency is incorrectly listed
as:
> <dependency>
> <groupId>velocity</groupId>
> <artifactId>velocity</artifactId>
> <version>1.6.2</version>
> </dependency>
> Changing the groupId to "org.apache.velocity" resolves the error.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message