chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prakhar Srivastava (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CHUKWA-643) Hicc builds with conflicting jar dependencies
Date Mon, 21 May 2012 07:50:40 GMT

    [ https://issues.apache.org/jira/browse/CHUKWA-643?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13279997#comment-13279997
] 

Prakhar Srivastava commented on CHUKWA-643:
-------------------------------------------

The hbase and hbase-tests dependency should be added as:
<dependency>
            <groupId>org.apache.hbase</groupId>
            <artifactId>hbase</artifactId>
            <version>0.92.0</version>
             <exclusions>
<exclusion>
<groupId>com.sun.jersey</groupId>
        <artifactId>jersey-core</artifactId>
        </exclusion>
<exclusion>
<groupId>com.sun.jersey</groupId>
        <artifactId>jersey-json</artifactId>
        </exclusion>
<exclusion>
<groupId>com.sun.jersey</groupId>
        <artifactId>jersey-server</artifactId>
        </exclusion>
      </exclusions>
          </dependency>

<dependency>
            <groupId>org.apache.hbase</groupId>
            <artifactId>hbase</artifactId>
            <classifier>tests</classifier>
            <version>0.92.0</version>
<exclusions>
<exclusion>
<groupId>com.sun.jersey</groupId>
        <artifactId>jersey-core</artifactId>
        </exclusion>
<exclusion>
<groupId>com.sun.jersey</groupId>
        <artifactId>jersey-json</artifactId>
        </exclusion>
<exclusion>
<groupId>com.sun.jersey</groupId>
        <artifactId>jersey-server</artifactId>
        </exclusion>
      </exclusions>
</dependency>

Also there is an issue with jsr311-api from jersey bindle so the jersey-bundle dependency
goes as follows:
<dependency>
            <groupId>com.sun.jersey</groupId>
            <artifactId>jersey-bundle</artifactId>
            <version>1.10</version>
            <exclusions>
                <exclusion>
                 <groupId>javax.ws.rs</groupId>
                 <artifactId>jsr311-api</artifactId>
                </exclusion>
            </exclusions>
          </dependency>

jsr-api 1.1 works fine.
                
> Hicc builds with conflicting jar dependencies
> ---------------------------------------------
>
>                 Key: CHUKWA-643
>                 URL: https://issues.apache.org/jira/browse/CHUKWA-643
>             Project: Chukwa
>          Issue Type: Bug
>            Reporter: Prakhar Srivastava
>             Fix For: 0.5.0
>
>
> http://search-hadoop.com/m/JiU6b2UpsEw1&subj=Unable+to+start+hicc

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message