chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Graham (JIRA)" <j...@apache.org>
Subject [jira] Updated: (CHUKWA-566) HBaseWriter does not set hbase.zookeeper.quorum properly
Date Fri, 10 Dec 2010 23:25:00 GMT

     [ https://issues.apache.org/jira/browse/CHUKWA-566?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bill Graham updated CHUKWA-566:
-------------------------------

    Attachment: CHUKWA-566-1.patch

Agreed, the hbase-site.xml approach is cleaner. I verified that this approach works with the
collector.

I've added a step to do this in the QuickStart wiki and patch 1 removes that block from conf/chukwa-collector-conf.xml.template.
Will commit shortly.

> HBaseWriter does not set hbase.zookeeper.quorum properly
> --------------------------------------------------------
>
>                 Key: CHUKWA-566
>                 URL: https://issues.apache.org/jira/browse/CHUKWA-566
>             Project: Chukwa
>          Issue Type: Bug
>            Reporter: Bill Graham
>            Assignee: Bill Graham
>         Attachments: CHUKWA-566-1.patch
>
>
> In my collector configs I set {{hbase.zookeeper.quorum}} to something other than {{localhost}}
and it does not get picked up by {{HBaseWriter}} when using HBase 0.90.0-rc1. In the constructor
something like this must be done:
> {noformat}
> hconf = HBaseConfiguration.create();
> hconf.set("hbase.zookeeper.quorum", conf.get("hbase.zookeeper.quorum"));
> {noformat}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message