chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerome Boulon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CHUKWA-345) Chunk.application and Chunk.streamName are redundant
Date Wed, 04 Nov 2009 01:11:32 GMT

    [ https://issues.apache.org/jira/browse/CHUKWA-345?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12773322#action_12773322
] 

Jerome Boulon commented on CHUKWA-345:
--------------------------------------

Eric,  I'm not sure why you want to define the serialization format and the transport protocol
at the same time? How you serialized the data and how you send them it's 2 things.

If your idea is to lock everyone to one single transport protocol HTTP then I'll put a -1
on it since there's no reason to lock the transport protocol and HTTP is not the one I'm using
for example.
Regarding the serialization format, this should applied only to the datasink file format,
the final output. For the same reason, if our serialization format is not supported in the
target language/env then I want to be free to use what ever make more sense for me and of
course I will have to convert it before writing the chunk to the dataSink file but hopefully
the serialization format will work for everyone.

Ari, if we're going to do the Map, why would you want to commit that patch? The pig contrib
project need to be updated if you want to commit that patch



> Chunk.application and Chunk.streamName are redundant
> ----------------------------------------------------
>
>                 Key: CHUKWA-345
>                 URL: https://issues.apache.org/jira/browse/CHUKWA-345
>             Project: Hadoop Chukwa
>          Issue Type: Bug
>          Components: data collection
>            Reporter: Ari Rabkin
>            Assignee: Ari Rabkin
>         Attachments: CHUKWA-345.patch
>
>
> The chunk interface has both an "application" field and a "stream name" field. But they
map to the same value.  Should cut one of those names, for clarity.
> I think "application" is the less descriptive name, and should be cut.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message