chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Yang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CHUKWA-345) Chunk.application and Chunk.streamName are redundant
Date Tue, 03 Nov 2009 23:20:35 GMT

    [ https://issues.apache.org/jira/browse/CHUKWA-345?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12773272#action_12773272
] 

Eric Yang commented on CHUKWA-345:
----------------------------------

+1 on removing application and keep stream name.

+1 on Map<String, String> approach, but we should define the serialization method on
HTTP protocol upfront.  Revising Chunk protocol should be in another JIRA with more discussions.

> Chunk.application and Chunk.streamName are redundant
> ----------------------------------------------------
>
>                 Key: CHUKWA-345
>                 URL: https://issues.apache.org/jira/browse/CHUKWA-345
>             Project: Hadoop Chukwa
>          Issue Type: Bug
>          Components: data collection
>            Reporter: Ari Rabkin
>            Assignee: Ari Rabkin
>         Attachments: CHUKWA-345.patch
>
>
> The chunk interface has both an "application" field and a "stream name" field. But they
map to the same value.  Should cut one of those names, for clarity.
> I think "application" is the less descriptive name, and should be cut.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message