chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ari Rabkin (JIRA)" <>
Subject [jira] Commented: (CHUKWA-345) Chunk.application and Chunk.streamName are redundant
Date Tue, 03 Nov 2009 23:44:33 GMT


Ari Rabkin commented on CHUKWA-345:

Eric, is that a +1 to commit this patch?

I'm open to a more general metadata framework; the intent of this patch was to clean up the
status quo, and make sure that the interface correctly describes what's going on underneath.
 I don't think it breaks backward-compatibility, unless there's a substantial volume of code
for processing Chukwa data that we don't know about.

> Chunk.application and Chunk.streamName are redundant
> ----------------------------------------------------
>                 Key: CHUKWA-345
>                 URL:
>             Project: Hadoop Chukwa
>          Issue Type: Bug
>          Components: data collection
>            Reporter: Ari Rabkin
>            Assignee: Ari Rabkin
>         Attachments: CHUKWA-345.patch
> The chunk interface has both an "application" field and a "stream name" field. But they
map to the same value.  Should cut one of those names, for clarity.
> I think "application" is the less descriptive name, and should be cut.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message