chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerome Boulon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CHUKWA-345) Chunk.application and Chunk.streamName are redundant
Date Tue, 28 Jul 2009 14:42:14 GMT

    [ https://issues.apache.org/jira/browse/CHUKWA-345?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12736089#action_12736089
] 

Jerome Boulon commented on CHUKWA-345:
--------------------------------------

the initial idea was to have one for the Application, like Hadoop and to set the streamname
to the actual file path. 
If you remove it make sure that you update all dependent source code like pig queries

> Chunk.application and Chunk.streamName are redundant
> ----------------------------------------------------
>
>                 Key: CHUKWA-345
>                 URL: https://issues.apache.org/jira/browse/CHUKWA-345
>             Project: Hadoop Chukwa
>          Issue Type: Bug
>          Components: data collection
>            Reporter: Ari Rabkin
>
> The chunk interface has both an "application" field and a "stream name" field. But they
map to the same value.  Should cut one of those names, for clarity.
> I think "application" is the less descriptive name, and should be cut.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message