chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerome Boulon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CHUKWA-330) controller should not create duplicates for adaptors with offsets
Date Wed, 24 Jun 2009 16:37:08 GMT

    [ https://issues.apache.org/jira/browse/CHUKWA-330?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12723620#action_12723620
] 

Jerome Boulon commented on CHUKWA-330:
--------------------------------------

Ari could you move the MD5's method to an helper class out of ChukwaAgent. 
There's no point in requiring the agent class on top of chukwa-hadoop-client.jar (so make
sure that chukwa-hadoop-client.jar is self contain)

> controller should not create duplicates for adaptors with offsets
> -----------------------------------------------------------------
>
>                 Key: CHUKWA-330
>                 URL: https://issues.apache.org/jira/browse/CHUKWA-330
>             Project: Hadoop Chukwa
>          Issue Type: Bug
>          Components: input tools
>            Reporter: Ari Rabkin
>            Assignee: Ari Rabkin
>            Priority: Blocker
>         Attachments: CHUKWA-330.patch
>
>   Original Estimate: 1.5h
>  Remaining Estimate: 1.5h
>
> The offset-of-first-byte param to FileTailingAdaptor is hashed into the default adaptor
name.  This changes the semantics of adaptor uniqueness, and broke metrics and the log4jappender.
> Proposed fix:
>   Add a new "addByName()" method to ChukwaAgentController that lets callers specify names.
 
>   Use this new method whenever finer control of adaptor uniqueness is needed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message