chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay <vijay2...@gmail.com>
Subject Re: Processor.
Date Fri, 29 May 2009 20:27:44 GMT
Hi Jerome,
Thanks for your input it works.... Actually i did the same and the Job
tracker was not showing for individual process.... counters did not show up
on my parser... I did receive the logs now and it seems to be working....

Regards,
</VJ>




On Tue, May 26, 2009 at 4:07 PM, Jerome Boulon <jboulon@yahoo-inc.com>wrote:

> Hi Vijay,
> Have you done this step?
> You can validate your input/output from demux by looking at the JTobTracker
> UI (demux counters) .
> /Jerome.
>
>
>  *   Parser registration
>
>     Edit chukwa-demux-conf.xml and add the following lines
>
>      <property>
>           <name><YourRecordType_Here></name>
>
> <value><org.apache.hadoop.chukwa.extraction.demux.processor.mapper.MyParser></value>
>           <description>Parser class for <YourRecordType_Here></description>
>      </property>
>
>
>
> On 5/26/09 11:29 AM, "Vijay" <vijay2win@gmail.com> wrote:
>
> *Hi,*
> I wrote a custome parser and
> inside org.apache.hadoop.chukwa.extraction.demux.processor.mapper for our
> tomcat logs.... but i dont see the process been done....
>
> I have something like
>        log.debug(recordEntry);
> i dont see these log entries.... also how do i know it is doing its work?
> JT
> UI shows the job is completed without any errors.... but i dont know if it
> did,.....
>
> I am following the instruction @
> http://wiki.apache.org/hadoop/Sending_information_to_Chukwa
>
> I think i am missing something.... Can you plz Advice?
>
> Thanks and Regards,
> </VJ>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message