chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manfred Huber (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CMIS-1075) Allow exclusion of Woodstox dependency
Date Thu, 09 May 2019 18:24:00 GMT

    [ https://issues.apache.org/jira/browse/CMIS-1075?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16836604#comment-16836604
] 

Manfred Huber commented on CMIS-1075:
-------------------------------------

Of course I did not see that you compile back to 1.8 ... So that one is correct.
Regarding the imports we can tell that we expierienced it differently... It seemed the classloader
tried to load the imports while loading the class and because of that we got an {{NoClasDefFoundError}}
at runtime... I can't tell you in detail how the class loading mechanism works, but I had
a discussion with [~struberg] about that and in the end it seemed he was right... In the moment
we moved the {{woodstox}} stuff into a private static inner class (which is handled as separate
.class file at runtime, therefore loaded separate) the exclusion worked fine. You still get
the error logged to the console but will be able to use the XMLIn - or OutputFactory loaded
by {{XMLInputFactory#newInstance}} ...

> Allow exclusion of Woodstox dependency
> --------------------------------------
>
>                 Key: CMIS-1075
>                 URL: https://issues.apache.org/jira/browse/CMIS-1075
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-commons
>    Affects Versions: OpenCMIS 1.1.0
>            Reporter: Manfred Huber
>            Priority: Critical
>              Labels: build, easyfix, patch, usability
>         Attachments: opencmis_xmlutils.patch
>
>   Original Estimate: 3h
>  Remaining Estimate: 3h
>
> We need to exlcude the Woodstox dependency from opencmis in our project, which is currently
not possible.
> If you exclude Woodstox you'll get an {{NoClassDefFoundError}} at runtime.
> The reason is that the class {{XMLUtils}} imports Woodstox classes. The attached patch
resolves this logic in a static inner class.
> Please note that we created this patch based on the {{chemistry-opencmis-1.1.0}} tag.
> I pushed this change to my fork of opencmis on [Github|https://github.com/downdrown/chemistry-opencmis/commit/ff047559e077cf4d57566a0f43e5f08d29d46b07]
but was not able to create a PR since there's no maintenance branch for 1.1.0.
> Edit: the above link to Github is wrong, the correct one is [this|https://github.com/downdrown/chemistry-opencmis/commit/26c3be7583ca6ad74ac30ac06c3b0ea02c588bfb]



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message