chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mignon, Laurent" <laurent.mig...@acsone.eu>
Subject Re: [DISCUSSION] Minimum Java version for OpenCMIS
Date Fri, 17 Nov 2017 06:48:54 GMT
+1 on java >= 8

Laurent


On Fri, Nov 17, 2017 at 12:39 AM, Florent Guillaume <fguillaume@nuxeo.com>
wrote:

> +1 on Java 8 as the minimum supported version.
>
> Florent
>
>
> On Thu, Nov 16, 2017 at 10:57 PM, Florian Müller <fmui@apache.org> wrote:
>
> > Hi all,
> >
> > Today, OpenCMIS requires Java 7 or later. Java 7 reached EOL in 2015.
> > In the near future, we will get into trouble when we try to update the
> > OpenCMIS dependencies. A few libraries OpenCMIS depends on already
> > dropped or are going to drop Java 7 support. Running on unmaintained and
> > outdated libraries doesn't sound like a good idea.
> >
> > Should we increase the minimum Java version to 8 in the next OpenCMIS
> > release?
> > Is there anyone who needs to run OpenCMIS on Java 7?
> >
> >
> > - Florian
> >
>
>
>
> --
> [image: Nuxeo]
>
> Florent Guillaume
> Head of R&D
>
> Twitter: @efge
>



-- 
*Laurent Mignon*
Senior software engineer

Tel: +352 20 21 10 20 32
Fax: +352 20 21 10 21
Email: laurent.mignon@acsone.eu

Acsone SA, Succursale de Luxembourg
22, Zone Industrielle
​ ​
​| L-8287 Kehlen, Luxembourg
TVA LU24733605
​ | ​RCS B160400​

​
Acsone sa/nv
Waterloo Atrium, Drève Richelle 167
 | B-1410 Waterloo
RPM Bruxelles 0835.207.216 RPR Brussel

www.acsone.eu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message