chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florent Guillaume <fguilla...@nuxeo.com>
Subject Re: [DISCUSSION] Minimum Java version for OpenCMIS
Date Thu, 16 Nov 2017 23:39:17 GMT
+1 on Java 8 as the minimum supported version.

Florent


On Thu, Nov 16, 2017 at 10:57 PM, Florian Müller <fmui@apache.org> wrote:

> Hi all,
>
> Today, OpenCMIS requires Java 7 or later. Java 7 reached EOL in 2015.
> In the near future, we will get into trouble when we try to update the
> OpenCMIS dependencies. A few libraries OpenCMIS depends on already
> dropped or are going to drop Java 7 support. Running on unmaintained and
> outdated libraries doesn't sound like a good idea.
>
> Should we increase the minimum Java version to 8 in the next OpenCMIS
> release?
> Is there anyone who needs to run OpenCMIS on Java 7?
>
>
> - Florian
>



-- 
[image: Nuxeo]

Florent Guillaume
Head of R&D

Twitter: @efge

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message