chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Müller (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CMIS-1042) Newly Created Object Not getting reflected
Date Wed, 02 Aug 2017 09:45:00 GMT

    [ https://issues.apache.org/jira/browse/CMIS-1042?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16110631#comment-16110631
] 

Florian Müller commented on CMIS-1042:
--------------------------------------

Can you tell us which CMIS server you are connecting to? Can you provide a code snippet to
reproduce the problem?
Why are you trying to call {{getObjectByPath}} after the root folder creation? The {{createFolder}}
method already returns a Folder object, which you can use to create a subfolder.

In your description, you mention the name of your root folder twice: "Root Folder" and "RootFolder"
(Note the space between "Root" and "Folder".)
In this name consistent in your code?

Oh, and update your OpenCMIS version. OpenCMIS 0.12 as been released 3 years ago. The current
version is OpenCMIS 1.1.0.

> Newly Created Object Not getting reflected
> ------------------------------------------
>
>                 Key: CMIS-1042
>                 URL: https://issues.apache.org/jira/browse/CMIS-1042
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>    Affects Versions: OpenCMIS 0.12.0
>            Reporter: aishwary
>
> Hi,
> I am trying to create a nested like of folder structure.
>        Root Folder
>        |
>        **********Folder1
>        |
>         **********Folder2
> So,when i am creating a root folder,on success of response i am trying to create Folder1.
> So,using session object i am looking for root folder using  objectByPath.So, i am checking
with "/RootFolder".
> But i am getting CmisObjectNotFoundException.But if i do the same thing in debug mode
it is working.
> I think the newly created object is not getting reflected instantly.
> Can you please look into the issue. 
> *



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message