chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Müller <f...@apache.org>
Subject Re: Requesting for help in querying sharepoint 2010 Via CMIS workbench
Date Mon, 23 May 2016 10:41:05 GMT
Hi Neza,

SharePoint 2010 has a few more issues than SharePoint 2013, but it is 
working too.

How do you connect with the CMIS Workbench? Are you using the Basic tab 
or the Expert tab?
I would recommend the Expert tab. Select "SharePoint 2010 AtomPub" and 
remove this line:
> org.apache.chemistry.opencmis.binding.auth.classname=org.apache.chemistry.opencmis.client.bindings.spi.NTLMAuthenticationProvider

Queries are POST requests. Can you try a different POST request and see 
if that is also failing. (For example, try creating a folder.)


- Florian


> Dear Florian,
> 
> Thanks for the response.
> 
> I am using SharePoint 2010 and the authentication method used is 
> standard.
> I am successfully being authenticated but my queries are the ones 
> failing.
> I had done several other tests with Sharepoint 2013, using the same
> authentication method and all of the queries are working perfectly. 
> However
> this seems like a SharePoint 2010 issue. OpenCMIS is configured on the
> server side. Unless If I have missed some steps.
> 
> I haven't tried using the Kerberos authentication to see. but when you 
> say
> SharePoint is known to work with basic and Kerberos authentication; are 
> you
> referring to all versions of SharePoint? or just the SharePoint 2013 
> server
> version? It's very hard for us to migrate all of our data from the 2010
> version to the 2013 version.  that's why having opencmis working with 
> the
> Sharepoint 2010 is what we want. especially for querying documents.
> 
> Thank you again for your feedback.
> 
> 
> 
> On Fri, May 20, 2016 at 8:20 PM, Florian Müller <fmui@apache.org> 
> wrote:
> 
>> Hi Neza,
>> 
>> SharePoint has its quirks and OpenCMIS provides workarounds for a few
>> issues, but in general OpenCMIS is working fine with SharePoint.
>> 
>> What authentication method are you using?
>> Basic authentication and Kerberos are known to work (if correctly
>> configured on the server side).
>> NTLM is not working. At first glance it seem to work, but eventually
>> HTTP POST requests (like query) will fail.
>> 
>> 
>> - Florian
>> 
>> 
>> > Hi Devs and Florian,
>> >
>> > My name is Neza. I am writing request for your help in cmis.
>> > I had tried using cmis workbench to query documents from the alfresco
>> side
>> > and it work perfectly, but when I moved to the sharepoint side, every
>> > single thing i do in my query return a: Runtime: Unauthorized exception.
>> IT
>> > seems that queried from sharepoint are not being interpreted. Even if I
>> do
>> > something very basic lile:
>> >
>> > SELECT * from cmis:document.
>> >
>> > This have been running me crazy, I googled alot around since monday and
>> did
>> > not et any answer to my case. A few suggestions but nothing let me to the
>> > solution.
>> >
>> > If you have already encountered this issue or can provide help, I would
>> > appreciate.
>> > My cmis workbench is: 0.13.0 and SP 2010.
>> >
>> > Regards,
>> > Neza
>> >
>> 

Mime
View raw message