chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bertrand Barraud (JIRA)" <>
Subject [jira] [Commented] (CMIS-961) Connection reset by peer when trying to upload a document over 2M to Alfresco 5.0.d
Date Fri, 29 Apr 2016 10:06:12 GMT


Bertrand Barraud commented on CMIS-961:

I encounter the same issue.
Wrote a script in python to upload file on Alfresco using cmislib
That works fine when uploading files under ~2Mo, but not over.

The script run on a CentOS 7. I tried to run the code on the same machine than Alfresco, with, localhost and with its actuall IP... same error.
Tried also remotely from another CentOS 7, same error.

Here is how I installed all my dependencies ( it's a copy of the readme document I created
for the project )
Note: On CentOS, replace apt-get by yum.

- Install setuptools for python
	sudo apt-get install python python-setuptools
- Install cmislib
	sudo easy_install cmislib
- Download the most recent version of cmislib-alfresco-extension
- Install cmislib-alfresco-extension
	sudo easy_install
- Install dependency
	sudo yum -y install python-lxml

Line Code breaking :
repoFolder.createDocument(documentName, contentFile=documentContent)

Errror Output:
urllib2.URLError: <urlopen error [Errno 104] Connection reset by peer>

Entire StackTrace :
Traceback (most recent call last):
  File "./", line 107, in <module>
    uploadDocumentAt(fileToUpload, filePath, repoFolder)
  File "./", line 75, in uploadDocumentAt
    repoFolder.createDocument(documentName, contentFile=documentContent)
  File "/usr/lib/python2.7/site-packages/cmislib-0.5.1-py2.7.egg/cmislib/", line 2756,
in createDocument
  File "/usr/lib/python2.7/site-packages/cmislib-0.5.1-py2.7.egg/cmislib/", line 1185,
in createDocument
  File "/usr/lib/python2.7/site-packages/cmislib-0.5.1-py2.7.egg/cmislib/", line 260,
in post
  File "/usr/lib/python2.7/site-packages/cmislib-0.5.1-py2.7.egg/cmislib/", line 286,
in post
  File "/usr/lib64/python2.7/", line 431, in open
    response = self._open(req, data)
  File "/usr/lib64/python2.7/", line 449, in _open
    '_open', req)
  File "/usr/lib64/python2.7/", line 409, in _call_chain
    result = func(*args)
  File "/usr/lib64/python2.7/", line 1244, in http_open
    return self.do_open(httplib.HTTPConnection, req)
  File "/usr/lib64/python2.7/", line 1214, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error [Errno 104] Connection reset by peer>

Did anyone find a work around in between this get solved ?

Hope this information will help to find a fix for this issue.

> Connection reset by peer when trying to upload a document over 2M to Alfresco 5.0.d
> -----------------------------------------------------------------------------------
>                 Key: CMIS-961
>                 URL:
>             Project: Chemistry
>          Issue Type: Bug
>          Components: python-cmislib
>    Affects Versions: cmislib 0.5.1
>         Environment: Alfresco 5.0.d community edition on an Ubuntu 14.04 LTS based system.
>            Reporter: Willem Ligtenberg
>            Assignee: Jeff Potts
>         Attachments: Sample-Bigish.pdf, Sample-Smallish.pdf
> Using Alfresco 5.0.a I was able to store large data files (up to 250M tested) in Alfresco
> doc = repo.createDocument(remoteFile, props, folder, localFile, properties['contentType'],
> Now, small files work, but any file larger than 2M fails.
> Uploading the same file using CMIS Workbench works fine.

This message was sent by Atlassian JIRA

View raw message