chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Müller (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CMIS-945) Query doesn't return updated values for several seconds
Date Tue, 25 Aug 2015 14:44:45 GMT

    [ https://issues.apache.org/jira/browse/CMIS-945?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14711381#comment-14711381
] 

Florian Müller commented on CMIS-945:
-------------------------------------

That's a known Alfresco behavior. OpenCMIS doesn't cache query result sets.

> Query doesn't return updated values for several seconds
> -------------------------------------------------------
>
>                 Key: CMIS-945
>                 URL: https://issues.apache.org/jira/browse/CMIS-945
>             Project: Chemistry
>          Issue Type: Bug
>          Components: opencmis-client
>    Affects Versions: OpenCMIS 0.13.0
>         Environment: Alfresco community 5.0.d on Linux, client in Java
>            Reporter: Tomaž Kolmanič
>
> When adding new documents (of our custom content type derived from document) where each
document has also property containing objectId of parent document new search returns for next
cca 7 seconds only documents before that add. Only after several seconds query returns correct
results/added docs for some parent doc. Example of query, where I search for child docs of
our custom content type:
> SELECT  cmis:objectId, cmis:name FROM ba:dok WHERE ba:parentId = '701c9c3c-87a6-45b7-9bee-a53c6fe854ae'
> It seems that because of caching query only after (very) long time finds added docs.
I tried first to set in solr4 in Alfresco every cache par. to 0 but it didn't help, still
I have to wait for correct results. So I suspect that problem is on CMIS side...?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message