chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshy Augustine <joshymaugust...@gmail.com>
Subject Re: Open CMIS and https
Date Wed, 17 Sep 2014 07:27:25 GMT
Thanks a ton!

Version of the remote alfresco server I am using is :Community - v4.2.0
(4480). The URL you suggested works beautifully. I was heading in the wrong
direction thinking that this was a https configuration issue!

Cheers,
Joshy

On Tue, Sep 16, 2014 at 9:14 PM, Gavin Cornwell <gavin.cornwell@alfresco.com
> wrote:

> Hi Joshy,
>
> What version of Alfresco Community are you using? Only 4.2f and later
> support that URL pattern, trying that URL against an older server will give
> you the result you’re seeing.
>
> Try using https://cmis-alfresco:8443/alfresco/cmisatom instead.
>
> Regards,
>
> Gavin
>
>
>
> On 16 Sep 2014, at 11:09, Joshy Augustine <joshymaugustine@gmail.com>
> wrote:
>
> > Thanks Florian & Jorge.
> >
> > Apologies if this is an alfresco question. I am using the URL
> >
> https://cmis-alfresco:8443/alfresco/api/-default-/public/cmis/versions/1.0/atom
> > to connect to an alfresco community instance running in https mode. I am
> > using Http Basic Authentication.
> >
> > However, using the Workbench, Open CMIS API as well as from the browser,
> I
> > am getting the following webpage when I try to connect.
> >
> > "Hi, you have reached the AXIS HTTP Servlet. Normally you would be
> hitting
> > this URL with a SOAP client rather than a browser.
> >
> > In case you are interested, my AXIS transport name appears to be
> '*http*' "
> > Trying to figure out what I am doing wrong? I am able to login using the
> > same credentials from a browser via URL
> > https://cmis-alfresco:8443/alfresco/faces/jsp/login.jsp
> >
> > Thanks,
> > Joshy
> >
> >
> > On Tue, Sep 16, 2014 at 8:07 AM, <Jorge.MARTIN-CUERVO@ext.ec.europa.eu>
> > wrote:
> >
> >> Hello,
> >>
> >> Just one tip. If you are using a certificate not signed by a CA, don't
> >> forget to add the certificate in your JVM installation.
> >>
> >> Regards.
> >>
> >>
> >> Jorge MARTIN CUERVO
> >>
> >> European Commission
> >> DG TRADE
> >> Unit A4
> >> CHAR 02/077
> >> B-1049 Brussels/Belgium
> >> +32 2 298 86 27
> >> jorge.martin-cuervo@ext.ec.europa.eu
> >>
> >> -----Original Message-----
> >> From: Florian Müller [mailto:fmui@apache.org]
> >> Sent: Monday, September 15, 2014 6:20 PM
> >> To: Joshy Augustine; dev
> >> Subject: Re: Open CMIS and https
> >>
> >> Hi Joshy,
> >>
> >> Just use a https URL to connect. There is no code change necessary.
> >>
> >> - Florian
> >>
> >>
> >>> Hi All,
> >>>
> >>> I am trying to understand what are the code changes(if any) required
> if I
> >>> need to use Open CMIS Client APIs to talk to a ECM Repository running
> in
> >>> https mode. I am currently using Atompub binding and Http Basic
> >>> Authentication.
> >>>
> >>> Any pointers in this area will be quite useful.
> >>>
> >>> Many Thanks,
> >>> Joshy
> >>
> >
> >
> >
> > --
> > Cheers,
> > Josh
>
>


-- 
Cheers,
Josh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message