chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Carter (JIRA)" <>
Subject [jira] [Commented] (CMIS-682) Using Chemistry OpenCMIS in ServiceMix 4.5
Date Tue, 02 Jul 2013 16:35:20 GMT


Jason Carter commented on CMIS-682:

We tried to Remove stax-api from our classpath...

We then started to get other Errors:
 - with linked exception:
[java.lang.ClassNotFoundException: com.sun.xml.bind.v2.ContextFactory not found from bundle

So we then tried to add back in Jaxb...
<Embed-Dependency>*;scope=compile|runtime;artifactId=!stax-api|jaxb-api </Embed-Dependency>

Now we see these errors dealing with ContentStreams...
org.apache.chemistry.opencmis.commons.exceptions.CmisConnectionException: Cannot access
null ...
Caused by: javax.xml.bind.MarshalException
 - with linked exception:
[javax.xml.transform.TransformerException: prefix cannot
be null or empty]

> Using Chemistry OpenCMIS in ServiceMix 4.5
> ------------------------------------------
>                 Key: CMIS-682
>                 URL:
>             Project: Chemistry
>          Issue Type: Bug
>    Affects Versions: OpenCMIS 0.9.0
>         Environment: Linux, ServiceMix 4.5
>            Reporter: Jason Carter
>            Priority: Critical
> Sorry if my acronyms are incorrect, newbie...
> We are using chemistry-opencmis-client-impl in a Module used by a Camel Route Bean. 
It is built using Maven.  And we are seeing an error when we try and call getRepositories
when running under ServiceMix 4.5:
> Caused by: Provider
not found
> 	at[:2.2.0]
> 	at[:2.2.0]
> 	at[:2.2.0]
> 	at[:2.2.0]
> 	at org.apache.chemistry.opencmis.commons.impl.XMLUtils.<clinit>(
> 	at org.apache.chemistry.opencmis.client.bindings.spi.atompub.AtomPubParser.parse(
> 	at org.apache.chemistry.opencmis.client.bindings.spi.atompub.AbstractAtomPubService.parse(
> 	at org.apache.chemistry.opencmis.client.bindings.spi.atompub.AbstractAtomPubService.getRepositoriesInternal(
> 	at org.apache.chemistry.opencmis.client.bindings.spi.atompub.RepositoryServiceImpl.getRepositoryInfos(
> 	at org.apache.chemistry.opencmis.client.bindings.impl.RepositoryServiceImpl.getRepositoryInfos(
> 	at org.apache.chemistry.opencmis.client.runtime.SessionFactoryImpl.getRepositories(
> 	at org.apache.chemistry.opencmis.client.runtime.SessionFactoryImpl.getRepositories(
> 	at com.avid.gam.assetsystem.CmisSessionHolder.initSession(
> 	at com.avid.gam.assetsystem.AlfrescoAssetSystem.createSession(
> 	at com.avid.gam.assetsystem.AssetSystemFactory.getByKey(
> 	at com.avid.gam.assetsystem.AssetSystemFactory.getAssetSystem(
> 	at com.avid.gam.route.GamRouteBean.saveOrder(
> As far as I can tell we are including all required dependencies in the POM.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message