chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajath Shashidhara <rajaths.raja...@gmail.com>
Subject CMIS Workbench problem
Date Wed, 31 Jul 2013 04:12:05 GMT
Hello,

I have created a new folder Inside the My_Folder-0-0 in the local immemory
repository named "moved1" programmatically.
Code:
Map<String,String> newFolderProps = new HashMap<String, String>();
            newFolderProps.put(PropertyIds.NAME, name);
            newFolderProps.put(PropertyIds.OBJECT_TYPE_ID,
ObjectType.FOLDER_BASETYPE_ID);
            try
            {
                getFolder().createFolder(newFolderProps);
                return true;
            }
            catch(CmisBaseException e)
            {
                return false;
            }

Here, name variable is "moved1"[image: Inline image 1]

This is the screenshot after creation of folder.
Now, when I try to getObjectbyPath from the session:
using: session.getObjectbyPath("/My_Folder-0-0/moved1") I'm getting a
CMisObjectNotFOundException.
the exception caught has a message containing
"/My_FOlder-0-0/My_FOlder-0-1" not found.

When I open the moved1 folder from the workbench, [image: Inline image 2]
U can clearly see that there is a conflict in the paths in the two places.
In the address bar, it shows a different path and in the properties bar it
shows the right path.

WHy is it so?
When I try to open "/My_Folder-0-0/moved1" why is it trying to open
"/My_FOlder-0-0/My_Dolder-0-1" ?

Is this a bug in opencmis?
-- 
Rajath S,
M.Sc(Hons.) Physics,
Birla Institute of Technology and Science - Pilani,
Pilani

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message