chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriele Columbro <colum...@gmail.com>
Subject Re: Using OpenCMIS 0.9.0 with Maven
Date Fri, 12 Jul 2013 17:45:31 GMT
Hi Manu,

you should be able to break the old version from coming in by adding an

<exclusion>

in the alfresco-repository dependency for each library you don't need to
come in transitively.

That way only the ones you are actually referencing will be brought in.

See [1] for more details on Maven dependency exclusions.

Hope this solves your issues!

Gab


On Fri, Jul 12, 2013 at 9:51 AM, Mano Swerts <m.swerts@aca-it.be> wrote:

> Hi Gabriele,
>
> I can indeed see the opencmis-commons-impl 0.7.0 jar referenced by the
> alfresco-repository dependency, just as I experienced. Here is the
> dependency tree:
>
> be.aca.alfresco:enhanced-it-test:jar:1.0-SNAPSHOT
> +- org.alfresco.enterprise:alfresco-repository:jar:4.1.4:provided
> |  +- org.alfresco.enterprise:alfresco-data-model:jar:4.1.4:provided
> |  +- org.alfresco.enterprise:alfresco-deployment:jar:4.1.4:provided
> |  +- org.alfresco.enterprise:alfresco-jlan-embed:jar:4.1.4:provided
> |  |  +- com.hazelcast:hazelcast:jar:1.9.4.6:provided
> |  |  \- com.hazelcast:hazelcast-spring:jar:1.9.4.6:provided
> |  +- org.alfresco.enterprise:alfresco-mbeans:jar:4.1.4:provided
> |  +- javax.mail:mail:jar:1.4:compile
> |  |  \- javax.activation:activation:jar:1.1:compile
> |  +- com.icegreen:greenmail:jar:1.3-alfresco-patched:provided
> |  +- commons-dbcp:commons-dbcp:jar:patched:1.4:provided
> |  +- commons-fileupload:commons-fileupload:jar:1.2.2:provided
> |  +- org.apache.commons:commons-compress:jar:1.4.1:provided
> |  |  \- org.tukaani:xz:jar:1.0:provided
> |  +- commons-codec:commons-codec:jar:1.5:compile
> |  +- commons-io:commons-io:jar:1.4:provided
> |  +- commons-net:commons-net:jar:2.2:provided
> |  +- commons-lang:commons-lang:jar:2.6:provided
> |  +- commons-pool:commons-pool:jar:1.5.5:provided
> |  +- commons-validator:commons-validator:jar:1.4.0:provided
> |  |  +- commons-beanutils:commons-beanutils:jar:1.8.3:provided
> |  |  +- commons-digester:commons-digester:jar:1.8:provided
> |  |  \- commons-logging:commons-logging:jar:1.1.1:compile
> |  +- org.apache.httpcomponents:httpclient-cache:jar:4.1.1:provided
> |  +- org.json:json:jar:20090211:provided
> |  +- javax.jcr:jcr:jar:1.0:provided
> |  +- org.jbpm:jbpm-jpdl:jar:3.3.1:provided
> |  +- com.ibm.icu:icu4j:jar:3.6.1:provided
> |  +- oro:oro:jar:2.0.8:provided
> |  +- com.googlecode.json-simple:json-simple:jar:1.1.1:compile
> |  +- rhino:js:jar:1.6R7-patched:provided
> |  +- org.springframework:spring-web:jar:3.0.5.RELEASE:provided
> |  |  \- aopalliance:aopalliance:jar:1.0:provided
> |  +- org.springmodules:spring-modules-jbpm31:jar:0.5:provided
> |  +- org.subethamail:subethasmtp:jar:3.1.6:provided
> |  |  \- com.google.code.findbugs:jsr305:jar:1.3.9:provided
> |  +- com.thoughtworks.xstream:xstream:jar:1.2.2:provided
> |  |  \- xpp3:xpp3_min:jar:1.1.3.4.O:provided
> |  +- com.sun.pdfview:pdfrenderer:jar:0.9.1-patched:provided
> |  +- net.sf.xmlrpc:xmlrpc:jar:1.3:provided
> |  +- com.benfante:JSlideShare:jar:0.6:provided
> |  +- bsf:bsf:jar:2.4.0:provided
> |  +- com.beetstra.jutf7:jutf7:jar:1.0.0:provided
> |  +- cglib:cglib:jar:2.2:provided
> |  +- org.slf4j:slf4j-api:jar:1.5.11:compile
> |  +- org.slf4j:slf4j-log4j12:jar:1.5.11:provided
> |  |  \- log4j:log4j:jar:1.2.14:compile
> |  +- net.sf.ehcache:ehcache-core:jar:2.0.0:provided
> |  +- org.beanshell:bsh:jar:1.3.0:provided
> |  +-
> org.apache.geronimo.specs:geronimo-annotation_1.0_spec:jar:1.1.1:provided
> |  +- org.apache.geronimo.specs:geronimo-jaxws_2.1_spec:jar:1.0:provided
> |  |  \-
> org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar:1.0.2:provided
> |  +-
> org.apache.geronimo.specs:geronimo-ws-metadata_2.0_spec:jar:1.1.2:provided
> |  +- org.jbpm:jbpm-identity:jar:3.3.1:provided
> |  +- net.java.dev.stax-utils:stax-utils:jar:20060502:provided
> |  +- org.freemarker:freemarker:jar:2.3.18-alfresco-patched-2:provided
> |  +- org.apache.cxf:cxf:jar:2.2.2-patched:provided
> |  +- org.codehaus.jackson:jackson-mapper-asl:jar:1.8.3:compile
> |  |  \- org.codehaus.jackson:jackson-core-asl:jar:1.8.3:compile
> |  +- org.apache.myfaces.core:myfaces-api:jar:1.1.8:provided
> |  |  \- javax.servlet:jstl:jar:1.1.0:provided
> |  +- org.apache.myfaces.core:myfaces-impl:jar:1.1.8:provided
> |  |  +- commons-el:commons-el:jar:1.0:provided
> |  |  \- commons-collections:commons-collections:jar:3.1:provided
> |  +- org.apache.xmlbeans:xmlbeans:jar:2.3.0:provided
> |  |  \- stax:stax-api:jar:1.0.1:compile
> |  +- org.apache.pdfbox:pdfbox:jar:1.7.0-alfresco-20130130:provided
> |  +- org.apache.pdfbox:fontbox:jar:1.7.0:provided
> |  +- org.apache.pdfbox:jempbox:jar:1.7.0:provided
> |  +- org.bouncycastle:bcprov-jdk15:jar:1.45:provided
> |  +- com.googlecode.mp4parser:isoparser:jar:1.0-RC-1:provided
> |  |  \- org.aspectj:aspectjrt:jar:1.6.11:provided
> |  +- com.drewnoakes:metadata-extractor:jar:2.6.2:provided
> |  |  \- com.adobe.xmp:xmpcore:jar:5.1.2:provided
> |  +- org.ccil.cowan.tagsoup:tagsoup:jar:1.2:compile
> |  +- org.apache.solr:solr-solrj:jar:1.4.1:provided
> |  |  \-
> org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1:provided
> |  +- net.sf:bliki:jar:3.0.2:provided
> |  +- net.sf.jsr107cache:jsr107cache:jar:1.0:provided
> |  +- javax.jws:jsr181-api:jar:1.0-MR1:provided
> |  +- javax.annotation:jsr250-api:jar:1.0:provided
> |  +- wsdl4j:wsdl4j:jar:1.6.2:provided
> |  +- org.apache.ws.commons.schema:XmlSchema:jar:1.4.5:provided
> |  +- org.jgroups:jgroups:jar:2.11.1.Final:provided
> |  +- com.sun.xml.fastinfoset:FastInfoset:jar:1.2.2:provided
> |  +- com.artofsolving:jodconverter:jar:2.1.0-alfresco-patched:provided
> |  +- org.openoffice:unoil:jar:3.1.0:provided
> |  +- org.openoffice:juh:jar:3.1.0:provided
> |  |  +- org.openoffice:jurt:jar:3.1.0:provided
> |  |  \- org.openoffice:ridl:jar:3.1.0:provided
> |  +- net.sf.javamusictag:jid3lib:jar:0.5.4:provided
> |  +- jmagick:jmagick:jar:6.2.4:provided
> |  +- org.openoffice:jut:jar:1.0-alfresco:provided
> |  +- org.htmlparser:htmlparser:jar:2.1:provided
> |  |  \- org.htmlparser:htmllexer:jar:2.1:provided
> |  +- org.apache.poi:poi:jar:3.9-beta1-20121129-alfresco-patched:provided
> |  +- org.apache.poi:poi-ooxml:jar:3.9-beta1-20121109:provided
> |  +- org.apache.poi:poi-scratchpad:jar:3.9-beta1-20121109:provided
> |  +- org.apache.poi:ooxml-schemas:jar:1.1:provided
> |  +- org.livetribe:livetribe-jsr223:jar:2.0.6:provided
> |  +- edu.ucar:netcdf:jar:4.2:provided
> |  +-
>
> org.springframework.extensions.surf:spring-surf-core-configservice:jar:1.2.0-M4:provided
> |  |  +-
> org.springframework.extensions.surf:spring-surf-core:jar:1.2.0-M4:provided
> |  |  +- dom4j:dom4j:jar:1.6.1:provided
> |  |  |  \- xml-apis:xml-apis:jar:1.0.b2:provided
> |  |  +-
> org.springframework:spring-context-support:jar:3.0.5.RELEASE:provided
> |  |  \- javax.servlet:servlet-api:jar:2.5:compile
> |  +-
> org.springframework.extensions.surf:spring-webscripts:jar:1.2.0-M4:provided
> |  |  +- org.apache.abdera:abdera-parser:jar:0.4.0-incubating:provided
> |  |  |  \- org.apache.ws.commons.axiom:axiom-impl:jar:1.2.5:provided
> |  |  |     \- org.apache.ws.commons.axiom:axiom-api:jar:1.2.5:provided
> |  |  +- org.apache.abdera:abdera-core:jar:0.4.0-incubating:provided
> |  |  |  +- org.apache.abdera:abdera-i18n:jar:0.4.0-incubating:provided
> |  |  |  \-
> org.apache.geronimo.specs:geronimo-activation_1.0.2_spec:jar:1.1:provided
> |  |  +-
> org.apache.abdera:abdera-extensions-json:jar:0.4.0-incubating:provided
> |  |  |  +- org.apache.abdera:abdera-server:jar:0.4.0-incubating:provided
> |  |  |  +-
> org.apache.abdera:abdera-extensions-main:jar:0.4.0-incubating:provided
> |  |  |  |  \-
> org.apache.abdera:abdera-client:jar:0.4.0-incubating:provided
> |  |  |  \-
> org.apache.abdera:abdera-extensions-html:jar:0.4.0-incubating:provided
> |  |  \- org.springframework:spring-webmvc:jar:3.0.5.RELEASE:provided
> |  +-
>
> org.springframework.extensions.surf:spring-webscripts-api:jar:1.2.0-M4:provided
> |  +- org.springframework.social:spring-social-core:jar:1.0.0.RC1:provided
> |  +-
>
> org.springframework.social:spring-social-linkedin:jar:1.0.0-20110711:provided
> |  +-
> org.springframework.social:spring-social-facebook:jar:1.0.0.RC1:provided
> |  +-
> org.springframework.social:spring-social-twitter:jar:1.0.0.RC1:provided
> |  +-
>
> org.apache.chemistry.opencmis:chemistry-opencmis-commons-impl:jar:0.7.0:compile
> |  +-
>
> org.apache.chemistry.opencmis:chemistry-opencmis-server-support:jar:0.7.0:provided
> |  +-
>
> org.apache.chemistry.opencmis:chemistry-opencmis-server-bindings:jar:classes:0.7.0:provided
> |  +- com.google.gdata:com.google.gdata.gdata-core:jar:1.0:provided
> |  +- com.google.gdata:com.google.gdata.gdata-media:jar:1.0:provided
> |  +- com.google.gdata:com.google.gdata.gdata-client:jar:1.0:provided
> |  +- com.google.gdata:com.google.gdata.gdata-docs:jar:3.0:provided
> |  +- com.google.gdata:gdata-youtube:jar:2.0:provided
> |  +- com.google.collections:google-collections:jar:1.0:provided
> |  +-
>
> org.springframework.security:spring-security-core:jar:3.1.0.RELEASE:provided
> |  |  \-
>
> org.springframework.security:spring-security-crypto:jar:3.1.0.RELEASE:provided
> |  +-
>
> org.springframework.social:spring-social-facebook-web:jar:1.0.0.RELEASE:provided
> |  +-
> org.springframework.social:spring-social-web:jar:1.0.0.RELEASE:provided
> |  |  \- javax.inject:javax.inject:jar:1:provided
> |  +- org.activiti:activiti-engine:jar:5.7-alf-20121211:provided
> |  \- org.activiti:activiti-spring:jar:5.7-alf-20121211:provided
> +- junit:junit:jar:4.11:compile
> |  \- org.hamcrest:hamcrest-core:jar:1.3:compile
> +- com.jayway.restassured:rest-assured:jar:1.8.0:compile
> |  +- org.codehaus.groovy:groovy-xml:jar:2.1.2:compile
> |  +- org.apache.httpcomponents:httpclient:jar:4.2.1:compile
> |  |  \- org.apache.httpcomponents:httpcore:jar:4.2.1:compile
> |  +- org.apache.httpcomponents:httpmime:jar:4.2.1:compile
> |  +- org.hamcrest:hamcrest-library:jar:1.2.1:compile
> |  +- com.jayway.restassured:json-path:jar:1.8.0:compile
> |  |  +- org.codehaus.groovy:groovy-json:jar:2.1.2:compile
> |  |  +- com.fasterxml.jackson.core:jackson-databind:jar:2.0.5:compile
> |  |  |  +-
> com.fasterxml.jackson.core:jackson-annotations:jar:2.0.5:compile
> |  |  |  \- com.fasterxml.jackson.core:jackson-core:jar:2.0.5:compile
> |  |  +- com.google.code.gson:gson:jar:1.7.2:compile
> |  |  \- com.jayway.restassured:rest-assured-common:jar:1.8.0:compile
> |  \- com.jayway.restassured:xml-path:jar:1.8.0:compile
> |     \- org.apache.commons:commons-lang3:jar:3.1:compile
> +- org.codehaus.groovy:groovy:jar:1.8.4:compile
> |  +- antlr:antlr:jar:2.7.7:compile
> |  +- asm:asm:jar:3.2:compile
> |  +- asm:asm-commons:jar:3.2:compile
> |  +- asm:asm-util:jar:3.2:compile
> |  +- asm:asm-analysis:jar:3.2:compile
> |  \- asm:asm-tree:jar:3.2:compile
> +-
>
> org.apache.chemistry.opencmis:chemistry-opencmis-client-impl:jar:0.8.0:compile
> |  +-
>
> org.apache.chemistry.opencmis:chemistry-opencmis-client-api:jar:0.8.0:compile
> |  +-
>
> org.apache.chemistry.opencmis:chemistry-opencmis-commons-api:jar:0.8.0:compile
> |  +-
>
> org.apache.chemistry.opencmis:chemistry-opencmis-client-bindings:jar:0.8.0:compile
> |  \- org.apache.felix:org.osgi.core:jar:1.0.0:compile
> +- org.alfresco.cmis.client:alfresco-opencmis-extension:jar:0.4:compile
> |  \- commons-httpclient:commons-httpclient:jar:3.1:compile
> +- com.h2database:h2:jar:1.3.170:test
> +- tk.skuro.alfresco:h2-support:jar:1.5:test
> +- org.springframework:spring-test:jar:3.0.5.RELEASE:test
> +- org.springframework:spring-context:jar:3.0.6.RELEASE:test
> |  +- org.springframework:spring-aop:jar:3.0.6.RELEASE:provided
> |  +- org.springframework:spring-beans:jar:3.0.6.RELEASE:provided
> |  +- org.springframework:spring-core:jar:3.0.6.RELEASE:provided
> |  +- org.springframework:spring-expression:jar:3.0.6.RELEASE:provided
> |  \- org.springframework:spring-asm:jar:3.0.6.RELEASE:provided
> +- org.alfresco.enterprise:alfresco-repository:jar:config:4.1.4:provided
> \- org.alfresco.enterprise:alfresco-data-model:jar:config:4.1.4:provided
>    +- org.alfresco.enterprise:alfresco-core:jar:4.1.4:provided
>    |  +- org.hibernate:hibernate:jar:3.2.6-alfresco-patched:provided
>    |  +- org.safehaus.jug:jug:jar:asl:2.0.0:provided
>    |  +- org.mybatis:mybatis:jar:patched:3.0.4:provided
>    |  +- org.mybatis:mybatis-spring:jar:1.0.1:provided
>    |  |  +- org.springframework:spring-tx:jar:3.0.5.RELEASE:provided
>    |  |  \- org.springframework:spring-jdbc:jar:3.0.5.RELEASE:provided
>    |  +- org.springframework:spring-orm:jar:3.0.5.RELEASE:provided
>    |  +- org.quartz-scheduler:quartz:jar:1.8.3-alfresco-patched:provided
>    |  +- com.sun.xml.bind:jaxb-xjc:jar:2.1.7:provided
>    |  +- com.sun.xml.bind:jaxb-impl:jar:2.1.11:compile
>    |  |  \- javax.xml.bind:jaxb-api:jar:2.1:compile
>    |  +- org.codehaus.guessencoding:guessencoding:jar:1.0:provided
>    |  \- javax.transaction:jta:jar:1.0.1b:provided
>    +- org.apache.lucene:lucene-core:jar:2.4.1:provided
>    +- org.apache.lucene:lucene-analyzers:jar:2.4.1:provided
>    +- org.apache.lucene:lucene-regex:jar:2.4.1:provided
>    +- org.apache.lucene:lucene-snowball:jar:2.4.1:provided
>    +- jaxen:jaxen:jar:1.1.3:provided
>    +- org.jibx:jibx-run:jar:1.2.3:provided
>    +- joda-time:joda-time:jar:1.2.1:provided
>    +- org.antlr:antlr:jar:3.4:provided
>    |  +- org.antlr:antlr-runtime:jar:3.4:provided
>    |  |  \- org.antlr:stringtemplate:jar:3.2.1:provided
>    |  \- org.antlr:ST4:jar:4.0.4:provided
>    +-
>
> org.apache.chemistry:chemistry-abdera:jar:0.1-incubating-unreleased:provided
>    +- org.codehaus.woodstox:wstx-asl:jar:3.2.4:compile
>    +- org.acegisecurity:acegi-security:jar:0.8.2_patched:provided
>    +- org.apache.ant:ant:jar:1.7.1:provided
>    |  \- org.apache.ant:ant-launcher:jar:1.7.1:provided
>    +- xerces:xercesImpl:jar:2.8.0:provided
>    +- xpp3:xpp3:jar:1.1.3_8:provided
>    +- org.apache.tika:tika-core:jar:1.3-20120801:provided
>    +- org.apache.tika:tika-parsers:jar:1.3-20120801:provided
>    +- org.gagravarr:vorbis-java-core:jar:0.3-20130206:provided
>    +- org.gagravarr:vorbis-java-tika:jar:0.3-20130206:provided
>    \- com.googlecode.juniversalchardet:juniversalchardet:jar:1.0.3:provided
>
> [image: Foto van Mano Swerts][image: email]m.swerts@aca-it.be[image:
> Phone]+32
> (0) 11 26 50 10[image: GSM]+32 (0) 484 80 81 45[image:
> twitter]manoswerts<https://twitter.com/#!/manoswerts>[image:
> Logo ACA IT-Solutions] <http://www.aca-it.be/>
>
> *ACA IT-Solutions NV*
> *HQ:* Ilgatlaan 5C | 3500 Hasselt
> T +32(0)11 26 50 10 | F +32(0)11 26 50 11
> www.aca-it.be | Twitter <https://twitter.com/aca_it> |
> Facebook<http://www.facebook.com/pages/ACA-IT-Solutions/278520212202909>
>  | Linkedin <http://www.linkedin.com/company/6524>
>
>
>
> On Thu, Jul 11, 2013 at 4:43 PM, Gabriele Columbro <gabriele@apache.org
> >wrote:
>
> > Hey Mano,
> >
> > did you try with a mvn dependency:tree of your project and maybe post the
> > output here?
> >
> > Thanks,
> >
> > Gab
> >
> >
> > On Thu, Jul 11, 2013 at 2:24 PM, Mano Swerts <m.swerts@aca-it.be> wrote:
> >
> > > Hi Gabriele,
> > >
> > > The default scope should be "compile" so normally that should work. I
> put
> > > the scope to "compile" explicitly, but still got the same error.
> > >
> > > In the POM I definitely see the 0.9.0 version referenced, but it seems
> to
> > > resolve to 0.7.0. Apparently the Alfresco repository dependency causes
> > > this:
> > >
> > > <dependency>
> > >     <groupId>${alfresco.groupId}</groupId>
> > >     <artifactId>alfresco-repository</artifactId>
> > > </dependency>
> > >
> > > So I think I'm stuck with the 0.7.0 or 0.8.0 version.
> > >
> > > Kind regards,
> > >
> > > Mano
> > >
> > > [image: Foto van Mano Swerts][image: email]m.swerts@aca-it.be[image:
> > > Phone]+32
> > > (0) 11 26 50 10[image: GSM]+32 (0) 484 80 81 45[image:
> > > twitter]manoswerts<https://twitter.com/#!/manoswerts>[image:
> > > Logo ACA IT-Solutions] <http://www.aca-it.be/>
> > >
> > > *ACA IT-Solutions NV*
> > > *HQ:* Ilgatlaan 5C | 3500 Hasselt
> > > T +32(0)11 26 50 10 | F +32(0)11 26 50 11
> > > www.aca-it.be | Twitter <https://twitter.com/aca_it> |
> > > Facebook<
> http://www.facebook.com/pages/ACA-IT-Solutions/278520212202909>
> > >  | Linkedin <http://www.linkedin.com/company/6524>
> > >
> > >
> > >
> > > On Wed, Jul 10, 2013 at 11:40 AM, Gabriele Columbro <
> gabriele@apache.org
> > > >wrote:
> > >
> > > > Hi Mano,
> > > >
> > > > that class org.apache.chemistry.opencmis.commons.impl.ClassLoaderUtil
> > was
> > > > actually added in 0.9.0 in the chemistry-opencmis-commons-impl
> project
> > > [1].
> > > >
> > > > But there is (properly) a dependency from
> > chemistry-opencmis-client-impl
> > > to
> > > > chemistry-opencmis-commons-impl (see POM [2]), with proper scope
> > runtime.
> > > >
> > > > Therefore this is probably something related to the dependency
> > resolution
> > > > on your side. Which scope are you declaring the <dependency> ? If
> it's
> > > > "provided", maybe that's breaking the transitive dependency chain
> [3].
> > > >
> > > > Hope this helps!
> > > >
> > > > Gab
> > > >
> > > > [1]
> > > >
> > > >
> > >
> >
> https://svn.apache.org/repos/asf/chemistry/opencmis/tags/chemistry-opencmis-0.9.0/chemistry-opencmis-commons/chemistry-opencmis-commons-impl/src/main/java/org/apache/chemistry/opencmis/commons/impl/ClassLoaderUtil.java
> > > > [2]
> > > >
> > > >
> > >
> >
> https://svn.apache.org/repos/asf/chemistry/opencmis/tags/chemistry-opencmis-0.9.0/chemistry-opencmis-client/chemistry-opencmis-client-impl/pom.xml
> > > > [3]
> > > >
> > > >
> > >
> >
> http://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html#Dependency_Scope
> > > >
> > > > On Wed, Jul 10, 2013 at 10:14 AM, Mano Swerts <m.swerts@aca-it.be>
> > > wrote:
> > > >
> > > > > Hi all,
> > > > >
> > > > > I used OpenCMIS 0.8.0 and now want to upgrade to 0.9.0. I updated
> my
> > > pom
> > > > > accordingly:
> > > > >
> > > > > <dependency>
> > > > > > <groupId>org.apache.chemistry.opencmis</groupId>
> > > > > > <artifactId>chemistry-opencmis-client-impl</artifactId>
> > > > > > <version>0.9.0</version>
> > > > > > </dependency>
> > > > >
> > > > >
> > > > > However I now get the following exception:
> > > > >
> > > > > ClassNotFoundException:
> > > > > > org.apache.chemistry.opencmis.commons.impl.ClassLoaderUtil
> > > > >
> > > > >
> > > > > Any ideas?
> > > > >
> > > > > Kind regards,
> > > > >
> > > > > Mano Swerts
> > > > >
> > > > > [image: Foto van Mano Swerts][image: email]m.swerts@aca-it.be
> [image:
> > > > > Phone]+32
> > > > > (0) 11 26 50 10[image: GSM]+32 (0) 484 80 81 45[image:
> > > > > twitter]manoswerts<https://twitter.com/#!/manoswerts>[image:
> > > > > Logo ACA IT-Solutions] <http://www.aca-it.be/>
> > > > >
> > > > > *ACA IT-Solutions NV*
> > > > > *HQ:* Ilgatlaan 5C | 3500 Hasselt
> > > > > T +32(0)11 26 50 10 | F +32(0)11 26 50 11
> > > > > www.aca-it.be | Twitter <https://twitter.com/aca_it> |
> > > > > Facebook<
> > > http://www.facebook.com/pages/ACA-IT-Solutions/278520212202909>
> > > > >  | Linkedin <http://www.linkedin.com/company/6524>
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > Gabriele Columbro
> > > > Principal Architect, Consulting Services
> > > > Alfresco Software <http://www.alfresco.com>
> > > > twitter: @mindthegabz <http://twitter.com/#!/mindthegabz>
> > > > blog: http://mindthegab.com
> > > >
> > > > *"Keyboard not found. Press F1 to continue"*
> > > >
> > >
> >
> >
> >
> > --
> > Gabriele Columbro
> > Principal Architect, Consulting Services
> > Alfresco Software <http://www.alfresco.com>
> > twitter: @mindthegabz <http://twitter.com/#!/mindthegabz>
> > blog: http://mindthegab.com
> >
> > *"Keyboard not found. Press F1 to continue"*
> >
>



-- 
Gabriele Columbro
Principal Architect, Consulting Services
Alfresco Software <http://www.alfresco.com>
twitter: @mindthegabz <http://twitter.com/#%21/mindthegabz>
blog: http://mindthegab.com
mobile: +31627565013

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message