chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mano Swerts <m.swe...@aca-it.be>
Subject Re: Using OpenCMIS 0.9.0 with Maven
Date Thu, 11 Jul 2013 12:24:24 GMT
Hi Gabriele,

The default scope should be "compile" so normally that should work. I put
the scope to "compile" explicitly, but still got the same error.

In the POM I definitely see the 0.9.0 version referenced, but it seems to
resolve to 0.7.0. Apparently the Alfresco repository dependency causes this:

<dependency>
    <groupId>${alfresco.groupId}</groupId>
    <artifactId>alfresco-repository</artifactId>
</dependency>

So I think I'm stuck with the 0.7.0 or 0.8.0 version.

Kind regards,

Mano

[image: Foto van Mano Swerts][image: email]m.swerts@aca-it.be[image: Phone]+32
(0) 11 26 50 10[image: GSM]+32 (0) 484 80 81 45[image:
twitter]manoswerts<https://twitter.com/#!/manoswerts>[image:
Logo ACA IT-Solutions] <http://www.aca-it.be/>

*ACA IT-Solutions NV*
*HQ:* Ilgatlaan 5C | 3500 Hasselt
T +32(0)11 26 50 10 | F +32(0)11 26 50 11
www.aca-it.be | Twitter <https://twitter.com/aca_it> |
Facebook<http://www.facebook.com/pages/ACA-IT-Solutions/278520212202909>
 | Linkedin <http://www.linkedin.com/company/6524>



On Wed, Jul 10, 2013 at 11:40 AM, Gabriele Columbro <gabriele@apache.org>wrote:

> Hi Mano,
>
> that class org.apache.chemistry.opencmis.commons.impl.ClassLoaderUtil was
> actually added in 0.9.0 in the chemistry-opencmis-commons-impl project [1].
>
> But there is (properly) a dependency from chemistry-opencmis-client-impl to
> chemistry-opencmis-commons-impl (see POM [2]), with proper scope runtime.
>
> Therefore this is probably something related to the dependency resolution
> on your side. Which scope are you declaring the <dependency> ? If it's
> "provided", maybe that's breaking the transitive dependency chain [3].
>
> Hope this helps!
>
> Gab
>
> [1]
>
> https://svn.apache.org/repos/asf/chemistry/opencmis/tags/chemistry-opencmis-0.9.0/chemistry-opencmis-commons/chemistry-opencmis-commons-impl/src/main/java/org/apache/chemistry/opencmis/commons/impl/ClassLoaderUtil.java
> [2]
>
> https://svn.apache.org/repos/asf/chemistry/opencmis/tags/chemistry-opencmis-0.9.0/chemistry-opencmis-client/chemistry-opencmis-client-impl/pom.xml
> [3]
>
> http://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html#Dependency_Scope
>
> On Wed, Jul 10, 2013 at 10:14 AM, Mano Swerts <m.swerts@aca-it.be> wrote:
>
> > Hi all,
> >
> > I used OpenCMIS 0.8.0 and now want to upgrade to 0.9.0. I updated my pom
> > accordingly:
> >
> > <dependency>
> > > <groupId>org.apache.chemistry.opencmis</groupId>
> > > <artifactId>chemistry-opencmis-client-impl</artifactId>
> > > <version>0.9.0</version>
> > > </dependency>
> >
> >
> > However I now get the following exception:
> >
> > ClassNotFoundException:
> > > org.apache.chemistry.opencmis.commons.impl.ClassLoaderUtil
> >
> >
> > Any ideas?
> >
> > Kind regards,
> >
> > Mano Swerts
> >
> > [image: Foto van Mano Swerts][image: email]m.swerts@aca-it.be[image:
> > Phone]+32
> > (0) 11 26 50 10[image: GSM]+32 (0) 484 80 81 45[image:
> > twitter]manoswerts<https://twitter.com/#!/manoswerts>[image:
> > Logo ACA IT-Solutions] <http://www.aca-it.be/>
> >
> > *ACA IT-Solutions NV*
> > *HQ:* Ilgatlaan 5C | 3500 Hasselt
> > T +32(0)11 26 50 10 | F +32(0)11 26 50 11
> > www.aca-it.be | Twitter <https://twitter.com/aca_it> |
> > Facebook<http://www.facebook.com/pages/ACA-IT-Solutions/278520212202909>
> >  | Linkedin <http://www.linkedin.com/company/6524>
> >
>
>
>
> --
> Gabriele Columbro
> Principal Architect, Consulting Services
> Alfresco Software <http://www.alfresco.com>
> twitter: @mindthegabz <http://twitter.com/#!/mindthegabz>
> blog: http://mindthegab.com
>
> *"Keyboard not found. Press F1 to continue"*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message