chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Müller <f...@apache.org>
Subject Re: Handling document ID including the pipr (|) character
Date Fri, 12 Jul 2013 18:12:08 GMT
Hi Tetsu,

Another thought:
When you fetch the object for the first time, there should be a self 
link in the Atom entry. Is this link correct?


- Florian


> Hi Tetsu,
>
> The pipe character shouldn't be a problem. You have already noticed that
> it is encoded when it is used in an URL parameter.
> The body of the check-in PUT request is essential. Can you check if the
> id is correct there?
> But it looks like a server issue. Even if the id is incorrect, the
> repository shouldn't return an "Internal Server Error". Can you also
> check the server logs if you find a hint?
>
> - Florian
>
>> Hi,
>>
>> I'm troubleshooting a problem with AtomPub binding to a repository on
>> which the document object contains the pipe (|) character, for
>> instance the document ID format may be "objectid-1|versionid-2".
>> When I check out the document, the corresponding PWC object ID seems
>> to be correctly obtained in my application but when I call checkIn()
>> method, I get an HTTP error 500 with "Internal Server Error" message
>> from the repository server.
>> By looking at TCP packet trace for "PUT" just before the error is
>> returned, the parameter for ID, "id=" does not have any ID specified.
>> So I'm wondering if it is because the document ID contains the pipe
>> (|) character.
>> Additionally, when the server returns the document object ID, it
>> replaces the pipe character with "%7C".
>> Since I'm fairly new to CMIS related technology so there are many
>> things to be learned.
>> Can anyone help me to accelerate my process for this trouble shooting
>> and to find out where the issue may be located?
>> I appreciate any help on this.
>> Thank you in advance.
>>
>> Regards,
>>
>> Tetsu
>>


Mime
View raw message