chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Webster <tim.webs...@gmail.com>
Subject Re: PortProvider class missing from Weblogic client bindings file
Date Fri, 01 Mar 2013 15:58:07 GMT
Hi Ron,

>From the 'how-to-use.txt' of he weblogic bindings jar file (see bolded bit)

This artifact is an OpenCMIS Client Bindings Jar that works on Weblogic.

In order to use the OpenCMIS client library in a web application on
Weblogic,
place the following jars into /WEB-INF/lib :

chemistry-opencmis-client-api-<version>.jar
chemistry-opencmis-client-impl-<version>.jar
chemistry-opencmis-client-binding-weblogic-<version>.jar
chemistry-opencmis-commons-api-<version>.jar
chemistry-opencmis-commons-impl-<version>.jar
slf4j-api-1.6.x.jar

Other dependencies mentioned in other parts of the OpenCMIS documentation
are
not required.* Make sure that the default OpenCMIS Client Bindings Jar*
*is not present.*


On Fri, Mar 1, 2013 at 3:55 PM, Ron DiFrango <
rdifrango@captechconsulting.com> wrote:

> Are you including this jar file because this is where it lives and I think
> it is required:
>
> <dependency>
>   <groupId>org.apache.chemistry.opencmis</groupId>
>   <artifactId>chemistry-opencmis-client-bindings</artifactId>
>   <version>0.8.0</version>
> </dependency>
>
> Ron DiFrango
> ________________________________________
> From: Tim Webster [tim.webster@gmail.com]
> Sent: Friday, March 01, 2013 10:19 AM
> To: dev@chemistry.apache.org
> Subject: PortProvider class missing from Weblogic client bindings file
>
> Hi,
>
> I emailed about this a couple of days ago, but I don't see a solution to
> it.
>
> The file chemistry-opencmis-client-bindings-weblogic-0.8.0.jar is missing
> the
> class
> org.apache.chemistry.opencmis.client.bindings.spi.webservices.PortProvider.
>  This class seems to be the default implementation of AbstractPortProvider
> and there is no indication that any other class should be used.
>
> Another implementation can be specified by setting the session parameter
> WEBSERVICES_PORT_PROVIDER_CLASS but the only other one present is
> WebspherePortProvider (which I in fact tried to use but it didn't work -
> should it?).
>
> Either way, there is nothing in the 'how-to-use.txt' that indicates another
> class should be specified.
>
> I tried a hack by putting PortProvider.class into the jar file, but this
> didn't work either (I got something along the lines of
> ' javax.xml.ws.WebServiceException: No Content-type in the header!'
>  However I don't know if this is being caused by the repository or not
> (it's IBM FileNet P8).
>
> Any thoughts?  I'm getting desperate!!
>
> Thanks,
>
> Tim
>



-- 
Check out my wine blog: http://timswineblog.blogspot.com/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message