chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tison Vincent <Tison.Vinc...@cg62.fr>
Subject RE: call of dotCmis from ashx
Date Fri, 21 Sep 2012 12:50:45 GMT
I can call successfully Alfresco from my browser and get the result but I can't directly change
the auth on a HttpWebRequest. There are some settings on the local policies where you can
change how the server handles Ntlm auth but whatever settings I used, it didn't help.
That may be the problem but I don't know how to analyse it.

Thanks for the idea !!



-----Message d'origine-----
De : Florian Müller [mailto:fmui@apache.org] 
Envoyé : vendredi 21 septembre 2012 14:38
À : dev@chemistry.apache.org
Cc : Tison Vincent
Objet : RE: call of dotCmis from ashx

 Hi Vincent,

 You may want to check if all components use the same NTML version. 
 There is NTMLv1 and NTLMv2.


 - Florian


> Hello,
>
> The ntlm auth is carried from the browser to IIS to Alfresco. The 
> websites are all internal.
> I have the ntlm binding since I contributed it ;) Our Alfresco is Ntlm 
> SSO enabled and so it should worked nicely theorically but it doesn't.
> I asked the group just in case someone would have encoutered such a 
> problem.
>
> I tried to call webscripts with jQuery straight from the browser 
> without the ashx handler or dotcmis. From there the call works and the 
> data is returned, ultimately the browser throws an error because the 
> result is not formatted in jsonp. That may be my way out but I would 
> prefer an handler.
>
>
> Vincent
>
>
>
> -----Message d'origine-----
> De : Florian Müller [mailto:fmui@apache.org] Envoyé : vendredi 21 
> septembre 2012 10:30 À : dev@chemistry.apache.org Cc : Tison Vincent 
> Objet : Re: call of dotCmis from ashx
>
>  Hi Vincent,
>
>  Where do you use NTLM? From the browser to your application or from 
> your application to Alfresco?
>  Which DotCMIS version do you use? The current DotCMIS release does 
> not  support NTLM, the next release will.
>  In general, NTML and CMIS are not a good fit. If you can you should 
> switch to basic auth.
>
>
>  - Florian
>
>
>
>> Hello !
>>
>> I know this is not an Alfresco mailing-list but since it may not be 
>> an Alfresco problem, i'm giving a try.
>>
>> I query an ashx which then query Alfresco through dotCMIS. I use the 
>> Ntlm authentication.
>> When I spied on the http queries, the auth is correctly sent to 
>> Alfresco but it ultimately fails with an error 500 (httpRequest in
>> binding\atompub\atompub.cs    Line : 439 )
>> Logs seem to indicate something wrong with the auth.
>>
>> Would I miss some server configuration to correct that ? or would you 
>> say it is fully Alfresco related ?
>>
>> Thanks a lot !!
>>
>> Vincent

Mime
View raw message