chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Müller <f...@apache.org>
Subject Re: OpenCMIS interface in Alfresco
Date Thu, 27 Sep 2012 10:47:02 GMT
 Hi Karsten,

 OpenCMIS only supports SOAP 1.1 out-of-the-box. It is possible to 
 activate SOAP 1.2, but that is not documented and untested.

 The getContentStream problem is not an OpenCMIS issue. The TCK contains 
 a test for that and works fine against the OpenCMIS InMemory repository, 
 the SAP NetWeaver Cloud Document Service and the public Alfresco server.


 - Florian


> Hello,
>
> I used to work with the older, native CMIS SOAP interface in
> Alfresco. When switching to OpenCMIS, I had a few challenges, I am
> using Alfresco CE 4.0d, which includes OpenCMIS 0.6.
>
> 1) it seems like OpenCMIS supports SOAP 1.1 only, while the native
> interface accepts 1.1 and 1.2 as well. Can you confirm this, I could
> not find anything in the documentation
>
> 2) More important, I am having a problem with getContentStream. When
> I call getContentStream without an offset and length parameter, I
> receive the content back. If I specify an offset, even with 0, the
> OpenCMIS interface does not return any response, not even a SOAP
> Fault. The client keeps waiting until time out. The Alfresco log 
> files
> do not show any error either.
>
> I assume this is more an OpenCMIS than an Alfresco issue.
>
> thanks for any help or suggestions


Mime
View raw message