chemistry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pankaj Tiwari <panky.tiw...@gmail.com>
Subject Re: Searching through folders hierarchy in alfresco community edition
Date Thu, 26 Jul 2012 18:41:50 GMT
Main Repository
   |
   |-------FileOne.txt
   |----- Data Dictionary
   |        |--------------------------- 1.txt
   |
   |----- User Homes
   |        |-----------------------------2.txt
   |
   |----- My Directory
            |------------------------------ MyFile.txt


When I execute "select cmis:name from cmis:document", it gives me back
FileOne.txt, 1.txt and 2.txt but not MyFile.txt

The only difference I see here is that My Directory is created by me
whereas the other two were present from the time of installation itself.

This may be related to alfresco configuration. I have not tested this
against any other repository, so it might be specific to alfresco.

Any pointers on this will be helpful.

Thanks,
Pankaj

On Thu, Jul 26, 2012 at 7:19 PM, Jeff Potts <jeffpotts01@gmail.com> wrote:

> Pankaj,
>
> I don't understand what this means:
> > the results are not shown from within the folders
> > I have created programmatically.
>
>
> The results that come back from a query are in a flat list. If you want to
> know an object's folder you can call getObjectParents on it.
>
> If I am misunderstanding what you are trying to do, please provide an
> example of what you expect the results to look like and a snippet of the
> results you are getting back as well as the code you are running to get
> those results.
>
> Also, if you suspect you are seeing something Alfresco-specific, please
> use the Alfresco forums. We have a forum dedicated to CMIS:
> https://forums.alfresco.com/en/viewforum.php?f=45
>
> Jeff
>
> On Jul 26, 2012, at 4:59 AM, Pankaj Tiwari wrote:
>
> > Hi All,
> >
> > I am using alfresco community edition and the repository I am using is
> > called 'Main Repository'.  When I try to run search on the repository the
> > results are displayed but the results are not shown from within the
> folders
> > I have created programmatically.
> >
> > Is this a alfresco configuration issue or a bug. Can somebody point me at
> > what could be going wrong in here.
> >
> > I am trying to execute query using Cmis Browser and the query used is the
> > default query viz. select cmis:objectId, cmis:name, cmis:objectTypeId
> > from cmis:document
> >
> > Thanks,
> > Pankaj
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message